aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-09-19 15:16:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-20 12:17:03 +0100
commite5443a0b5a70bf054cbeb6ff1fd6b5ef9d2347f8 (patch)
tree5566bd90bc28ad2d00de0447b92250bed45a4684 /meta/recipes-graphics
parent908b179b798704db74c886ec4c70c0942b09cb00 (diff)
downloadopenembedded-core-e5443a0b5a70bf054cbeb6ff1fd6b5ef9d2347f8.tar.gz
x11vnc: respect zeroconf DISTRO_FEATURE to enable Avahi support
There's a standard way of announcing VNC services over mDNS that x11vnc supports, so respect the feature and enable/disable it. Also re-order the statements and drop the redundant PR. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/x11vnc/x11vnc_0.9.13.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-graphics/x11vnc/x11vnc_0.9.13.bb b/meta/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
index 0abc84ad2d..24c42d131d 100644
--- a/meta/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
+++ b/meta/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
@@ -7,10 +7,6 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=361b6b837cad26c6900a926b62aada5f \
file://x11vnc/x11vnc.h;endline=33;md5=6f95dc6535467d7ee1563fd434fb372e"
-DEPENDS = "openssl virtual/libx11 libxext avahi jpeg zlib libxfixes libxrandr libxdamage libxtst"
-
-PR = "r0"
-
SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/x11vnc/${PV}/x11vnc-${PV}.tar.gz\
file://starting-fix.patch \
file://endian-fix.patch "
@@ -18,5 +14,9 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/x11vnc/${PV}/x11vnc-${PV}.tar.gz\
SRC_URI[md5sum] = "a372ec4fe8211221547b1c108cf56e4c"
SRC_URI[sha256sum] = "f6829f2e629667a5284de62b080b13126a0736499fe47cdb447aedb07a59f13b"
+DEPENDS = "openssl virtual/libx11 libxext jpeg zlib libxfixes libxrandr libxdamage libxtst"
+
inherit autotools
+PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)}"
+PACKAGECONFIG[avahi] = "--with-avahi,--without-avahi,avahi"