aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland
diff options
context:
space:
mode:
authorAlexandru DAMIAN <alexandru.damian@intel.com>2012-12-04 14:26:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-18 12:59:08 +0000
commit41538cb52f3a79c52aa37c34d8f275010b93c2c2 (patch)
tree7ea51d07911b8279e819a8f59ff6c4e37e577fe3 /meta/recipes-graphics/wayland
parent263508220674321473a746a137bb5d4b21c55119 (diff)
downloadopenembedded-core-41538cb52f3a79c52aa37c34d8f275010b93c2c2.tar.gz
wayland: add Wayland protocol library
Wayland is a protocol for a client application to display user interface windows through the use of a compositing window manager. This package include the specific set of server-side and client-side C libraries that implement the protocol. Signed-off-by: Alexandru DAMIAN <alexandru.damian@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.0.3.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.0.3.bb b/meta/recipes-graphics/wayland/wayland_1.0.3.bb
new file mode 100644
index 0000000000..6e01b227f0
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.0.3.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Wayland, a protocol between a compositor and clients"
+DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
+as well as a C library implementation of that protocol. The compositor can be \
+a standalone display server running on Linux kernel modesetting and evdev \
+input devices, an X application, or a wayland client itself. The clients can \
+be traditional applications, X servers (rootless or fullscreen) or other \
+display servers."
+HOMEPAGE = "http://wayland.freedesktop.org"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1d4476a7d98dd5691c53d4d43a510c72 \
+ file://src/wayland-server.c;endline=21;md5=079ae21dbf98ada52ec23744851b0a5c"
+
+SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
+SRC_URI[md5sum] = "eebe23571fd4f9ceacc583238e5a8ae9"
+SRC_URI[sha256sum] = "f6be5ee11ba534baaa116350b5efb874bf9963bf3fb18bcf40130317e83a5913"
+
+inherit autotools pkgconfig
+
+# We need wayland-native for the wayland-scanner utility
+BBCLASSEXTEND = "native"
+
+DEPENDS_virtclass-native = "expat-native"
+DEPENDS = "expat wayland-native"
+
+EXTRA_OECONF_virtclass-native = "--disable-documentation"
+EXTRA_OECONF = "--disable-documentation --disable-scanner"
+
+# Wayland installs a M4 macro for other projects to use. This M4 macro includes
+# a path to a Makefile fragment to get the rules to generate stubs from protocol
+# description files. The paths to the sysroot end up incorrect, so fix them.
+do_configure_append_class-native() {
+ sed -e 's,@prefix@,${STAGING_DIR_NATIVE},g' \
+ -e 's,@exec_prefix@,${STAGING_DIR_NATIVE},g' \
+ -e 's,@bindir@,${STAGING_BINDIR_NATIVE},g' \
+ -e 's,@datarootdir@,${STAGING_DATADIR_NATIVE},g' \
+ ${S}/wayland-scanner.m4.in > ${B}/wayland-scanner.m4
+}