aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-05-31 14:22:56 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-04 15:53:46 +0100
commit02e486ec9321fd3d7769c70979207335847a8f92 (patch)
tree2c605f7187ea92e03c782cbf8d15a8ccc3a63247 /meta/recipes-graphics/wayland
parent04234dfc2bc4c1bc4f3840fa9a162b25ba6ba049 (diff)
downloadopenembedded-core-02e486ec9321fd3d7769c70979207335847a8f92.tar.gz
weston: add a weston-launch group
For weston-launch to be used by a non-root user, the user either needs to be a member of the weston-launch group or own an active systemd user session. Create this group so users can be members of it. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland')
-rw-r--r--meta/recipes-graphics/wayland/weston_1.0.6.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.0.6.bb b/meta/recipes-graphics/wayland/weston_1.0.6.bb
index dd17c03ad1..07811f2831 100644
--- a/meta/recipes-graphics/wayland/weston_1.0.6.bb
+++ b/meta/recipes-graphics/wayland/weston_1.0.6.bb
@@ -12,7 +12,7 @@ SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
SRC_URI[md5sum] = "63202129d66d5514e572814da5dfa1f7"
SRC_URI[sha256sum] = "c833bc4dc8667561d2639b57220541531c039aa9332ce2a7022a3c466eb894f1"
-inherit autotools pkgconfig
+inherit autotools pkgconfig useradd
DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 mtdev jpeg"
DEPENDS += "wayland mesa virtual/egl"
@@ -57,3 +57,6 @@ FILES_${PN}-examples = "${bindir}/*"
RDEPENDS_${PN} += "xkeyboard-config"
RRECOMMENDS_${PN} = "liberation-fonts"
+
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN} = "--system weston-launch"