aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.3.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-11-07 11:55:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-08 17:27:55 +0000
commit97a3c3bc969ffb7f0c21755c733111d2f4ef8d20 (patch)
tree51d22049cbb8b4b971b1a0bb2f1616c506e7f31e /meta/recipes-graphics/wayland/wayland_1.3.0.bb
parent927a0065c7ce03465125b5b91258c337d2ac7bd2 (diff)
downloadopenembedded-core-97a3c3bc969ffb7f0c21755c733111d2f4ef8d20.tar.gz
wayland: upgrade to 1.3.0
wayland-scanner now uses pkg-config instead of hard-coding paths, so edit the script to use pkg-config-native. Based on work by Ewan Le Bideau-Canevet <Ewan.LEBIDEAU-CANEVET@eurogiciel.fr>. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.3.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.3.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.3.0.bb b/meta/recipes-graphics/wayland/wayland_1.3.0.bb
new file mode 100644
index 0000000000..212e08ae1b
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.3.0.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Wayland, a protocol between a compositor and clients"
+DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
+as well as a C library implementation of that protocol. The compositor can be \
+a standalone display server running on Linux kernel modesetting and evdev \
+input devices, an X application, or a wayland client itself. The clients can \
+be traditional applications, X servers (rootless or fullscreen) or other \
+display servers."
+HOMEPAGE = "http://wayland.freedesktop.org"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1d4476a7d98dd5691c53d4d43a510c72 \
+ file://src/wayland-server.c;endline=21;md5=079ae21dbf98ada52ec23744851b0a5c"
+
+SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
+SRC_URI[md5sum] = "d16d27081e0871de82d08840c2f133fc"
+SRC_URI[sha256sum] = "2e817685f68a26acd19964d69ddbc4549ba5412114ad95e1a9f5934cce470d6e"
+
+SRC_URI_append_class-native = " file://just-scanner.patch"
+
+inherit autotools pkgconfig
+
+# We need wayland-native for the wayland-scanner utility
+BBCLASSEXTEND = "native"
+
+DEPENDS_virtclass-native = "expat-native libffi-native"
+DEPENDS = "expat libffi wayland-native"
+
+EXTRA_OECONF_virtclass-native = "--disable-documentation"
+EXTRA_OECONF = "--disable-documentation --disable-scanner"
+
+# Wayland installs a M4 macro for other projects to use, which uses the target
+# pkg-config to find files. Replace pkg-config with pkg-config-native.
+do_install_append_class-native() {
+ sed -e 's,PKG_CHECK_MODULES(.*),,g' \
+ -e 's,$PKG_CONFIG,pkg-config-native,g' \
+ -i ${D}/${datadir}/aclocal/wayland-scanner.m4
+}