summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2012-08-02 17:49:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:45:09 +0100
commite4039eb74b20e96d4b8837cd58cf2d13d091e1ad (patch)
treee72989c8eb4b2f822418d718de5aa7c29924ac73 /meta/recipes-graphics/mesa/mesa
parentbe882417cf432fe79a843cea4439503f286206cf (diff)
downloadopenembedded-core-e4039eb74b20e96d4b8837cd58cf2d13d091e1ad.tar.gz
mesa: Update to 8.0.4 (latest stable version)
- The license file has changed, but the project still has the same license - Patches have been rebased on top of the 8.0 branch. crossfix.patch and crossfix-mklib.patch have been merged as they address the same problem Signed-off-by: Damien Lespiau <damien.lespiau@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa')
-rw-r--r--meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch52
-rw-r--r--meta/recipes-graphics/mesa/mesa/0002-cross-compile.patch (renamed from meta/recipes-graphics/mesa/mesa/crossfix-mklib.patch)39
-rw-r--r--meta/recipes-graphics/mesa/mesa/0003-fix-for-x32.patch (renamed from meta/recipes-graphics/mesa/mesa/mesa_fix_for_x32.patch)30
-rw-r--r--meta/recipes-graphics/mesa/mesa/crossfix.patch18
-rw-r--r--meta/recipes-graphics/mesa/mesa/uclibc.patch42
5 files changed, 103 insertions, 78 deletions
diff --git a/meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch b/meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch
new file mode 100644
index 0000000000..d39270a48b
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch
@@ -0,0 +1,52 @@
+Compile with uclibc
+
+Upstream-Status: Pending
+---
+ configure.ac | 3 +++
+ src/glsl/strtod.c | 2 +-
+ src/mesa/main/imports.c | 2 +-
+ 3 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index fbaa376..454dad2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -543,6 +543,9 @@ AC_SUBST([DLOPEN_LIBS])
+ dnl See if posix_memalign is available
+ AC_CHECK_FUNC([posix_memalign], [DEFINES="$DEFINES -DHAVE_POSIX_MEMALIGN"])
+
++dnl See if newlocale is available
++AC_CHECK_FUNCS_ONCE(newlocale)
++
+ dnl SELinux awareness.
+ AC_ARG_ENABLE([selinux],
+ [AS_HELP_STRING([--enable-selinux],
+diff --git a/src/glsl/strtod.c b/src/glsl/strtod.c
+index a876e13..9fce7e9 100644
+--- a/src/glsl/strtod.c
++++ b/src/glsl/strtod.c
+@@ -45,7 +45,7 @@ double
+ glsl_strtod(const char *s, char **end)
+ {
+ #if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__) && \
+- !defined(__HAIKU__)
++ !defined(__HAIKU__) && defined (HAVE_NEWLOCALE)
+ static locale_t loc = NULL;
+ if (!loc) {
+ loc = newlocale(LC_CTYPE_MASK, "C", NULL);
+diff --git a/src/mesa/main/imports.c b/src/mesa/main/imports.c
+index d3727ef..363bf32 100644
+--- a/src/mesa/main/imports.c
++++ b/src/mesa/main/imports.c
+@@ -767,7 +767,7 @@ float
+ _mesa_strtof( const char *s, char **end )
+ {
+ #if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__) && \
+- !defined(ANDROID) && !defined(__HAIKU__)
++ !defined(ANDROID) && !defined(__HAIKU__) && defined (HAVE_NEWLOCALE)
+ static locale_t loc = NULL;
+ if (!loc) {
+ loc = newlocale(LC_CTYPE_MASK, "C", NULL);
+--
+1.7.10.4
+
diff --git a/meta/recipes-graphics/mesa/mesa/crossfix-mklib.patch b/meta/recipes-graphics/mesa/mesa/0002-cross-compile.patch
index dc0822891b..dc8e9948a3 100644
--- a/meta/recipes-graphics/mesa/mesa/crossfix-mklib.patch
+++ b/meta/recipes-graphics/mesa/mesa/0002-cross-compile.patch
@@ -1,4 +1,7 @@
-This patch is ported from WindRiver linux and to fix cross compile failure.
+cross compile
+
+This patch is ported from WindRiver linux and to fix cross compile
+failure.
And original commits are:
commit 8d5ccc8113e1b51b0529a00c18a4aba956247e1b
@@ -7,10 +10,15 @@ commit 5c4212084b871a0c0fb7d174280ec9a634637deb
Upstream-Status: Pending
Signed-off-by: Kang Kai <kai.kang@windriver.com>
+---
+ bin/mklib | 24 ++++++++++++------------
+ 1 file changed, 12 insertions(+), 12 deletions(-)
---- Mesa-7.10.2/bin/mklib.orig 2011-09-28 16:15:34.170000074 +0800
-+++ Mesa-7.10.2/bin/mklib 2011-09-28 16:15:42.370000073 +0800
-@@ -49,8 +49,8 @@
+diff --git a/bin/mklib b/bin/mklib
+index 9bac29e..b33aa90 100755
+--- a/bin/mklib
++++ b/bin/mklib
+@@ -49,8 +49,8 @@ expand_archives() {
/*) ;;
*) FILE="$ORIG_DIR/$FILE" ;;
esac
@@ -21,7 +29,7 @@ Signed-off-by: Kang Kai <kai.kang@windriver.com>
for MEMBER in $MEMBERS ; do
NEWFILES="$NEWFILES $DIR/$MEMBER"
done
-@@ -77,7 +77,7 @@
+@@ -77,7 +77,7 @@ expand_archives() {
make_ar_static_lib() {
OPTS=$1
shift;
@@ -30,7 +38,7 @@ Signed-off-by: Kang Kai <kai.kang@windriver.com>
shift;
LIBNAME=$1
shift;
-@@ -87,11 +87,11 @@
+@@ -87,11 +87,11 @@ make_ar_static_lib() {
rm -f ${LIBNAME}
# make static lib
@@ -45,7 +53,7 @@ Signed-off-by: Kang Kai <kai.kang@windriver.com>
fi
echo ${LIBNAME}
-@@ -313,9 +313,9 @@
+@@ -313,9 +313,9 @@ case $ARCH in
if [ "x$LINK" = "x" ] ; then
# -linker was not specified so set default link command now
if [ $CPLUSPLUS = 1 ] ; then
@@ -57,7 +65,19 @@ Signed-off-by: Kang Kai <kai.kang@windriver.com>
fi
fi
-@@ -531,9 +531,9 @@
+@@ -535,9 +535,9 @@ case $ARCH in
+ if [ "x$LINK" = "x" ] ; then
+ # -linker was not specified so set default link command now
+ if [ $CPLUSPLUS = 1 ] ; then
+- LINK=g++
++ LINK=$CXX
+ else
+- LINK=gcc
++ LINK=$CC
+ fi
+ fi
+
+@@ -903,9 +903,9 @@ case $ARCH in
if [ "x$LINK" = "x" ] ; then
# -linker was not specified so set default link command now
if [ $CPLUSPLUS = 1 ] ; then
@@ -69,3 +89,6 @@ Signed-off-by: Kang Kai <kai.kang@windriver.com>
fi
fi
+--
+1.7.10.4
+
diff --git a/meta/recipes-graphics/mesa/mesa/mesa_fix_for_x32.patch b/meta/recipes-graphics/mesa/mesa/0003-fix-for-x32.patch
index f072c34f71..2d6a150e42 100644
--- a/meta/recipes-graphics/mesa/mesa/mesa_fix_for_x32.patch
+++ b/meta/recipes-graphics/mesa/mesa/0003-fix-for-x32.patch
@@ -1,16 +1,19 @@
Upstream-Status: Pending
-Using uname like this when cross compiling is a really bad idea. We
-provide the correct linker flags, lets just assume we can get this
+Using uname like this when cross compiling is a really bad idea. We
+provide the correct linker flags, lets just assume we can get this
right ourselves.
RP 2012/04/26
+---
+ bin/mklib | 16 ----------------
+ 1 file changed, 16 deletions(-)
-Index: Mesa-7.11/bin/mklib
-===================================================================
---- Mesa-7.11.orig/bin/mklib 2012-04-26 19:43:20.729150109 +0000
-+++ Mesa-7.11/bin/mklib 2012-04-26 20:30:22.421086163 +0000
-@@ -330,13 +330,7 @@
+diff --git a/bin/mklib b/bin/mklib
+index b33aa90..16cb017 100755
+--- a/bin/mklib
++++ b/bin/mklib
+@@ -330,15 +330,7 @@ case $ARCH in
;;
esac
@@ -18,13 +21,15 @@ Index: Mesa-7.11/bin/mklib
- # environment. If so, pass -m32 flag to linker.
set ${OBJECTS}
- ABI32=`file $1 | grep 32-bit`
-- if [ "${ABI32}" -a `uname -m` = "x86_64" ] ; then
+- ARM=`file $1 | grep ARM`
+- # Do not add "-m32" option for arm.
+- if [ -z "$ARM" -a "${ABI32}" -a `uname -m` = "x86_64" ] ; then
- OPTS="-m32 ${OPTS}"
- fi
if [ "${ALTOPTS}" ] ; then
OPTS=${ALTOPTS}
-@@ -387,13 +381,7 @@
+@@ -389,15 +381,7 @@ case $ARCH in
# exptmp is removed below
fi
@@ -32,9 +37,14 @@ Index: Mesa-7.11/bin/mklib
- # environment. If so, pass -m32 flag to linker.
set ${OBJECTS}
- ABI32=`file $1 | grep 32-bit`
-- if [ "${ABI32}" -a `uname -m` = "x86_64" ] ; then
+- ARM=`file $1 | grep ARM`
+- # Do not add "-m32" option for arm.
+- if [ -z "$ARM" -a "${ABI32}" -a `uname -m` = "x86_64" ] ; then
- OPTS="-m32 ${OPTS}"
- fi
if [ "${ALTOPTS}" ] ; then
OPTS=${ALTOPTS}
fi
+--
+1.7.10.4
+
diff --git a/meta/recipes-graphics/mesa/mesa/crossfix.patch b/meta/recipes-graphics/mesa/mesa/crossfix.patch
deleted file mode 100644
index d300e2f1b3..0000000000
--- a/meta/recipes-graphics/mesa/mesa/crossfix.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Upstream-Status: Pending
-
-Index: Mesa-7.5/bin/mklib
-===================================================================
---- Mesa-7.5.orig/bin/mklib 2009-08-12 13:01:34.000000000 +0100
-+++ Mesa-7.5/bin/mklib 2009-08-12 13:04:19.000000000 +0100
-@@ -234,9 +234,9 @@
- if [ "x$LINK" = "x" ] ; then
- # -linker was not specified so set default link command now
- if [ $CPLUSPLUS = 1 ] ; then
-- LINK=g++
-+ LINK=$CXX
- else
-- LINK=gcc
-+ LINK=$CC
- fi
- fi
-
diff --git a/meta/recipes-graphics/mesa/mesa/uclibc.patch b/meta/recipes-graphics/mesa/mesa/uclibc.patch
deleted file mode 100644
index 49d0234ece..0000000000
--- a/meta/recipes-graphics/mesa/mesa/uclibc.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Upstream-Status: Pending
-
-Index: Mesa-7.10.2/src/mesa/main/imports.c
-===================================================================
---- Mesa-7.10.2.orig/src/mesa/main/imports.c 2011-03-01 12:57:29.000000000 -0800
-+++ Mesa-7.10.2/src/mesa/main/imports.c 2011-07-20 19:08:49.441785510 -0700
-@@ -757,7 +757,7 @@
- float
- _mesa_strtof( const char *s, char **end )
- {
--#if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__)
-+#if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__) && defined (HAVE_NEWLOCALE)
- static locale_t loc = NULL;
- if (!loc) {
- loc = newlocale(LC_CTYPE_MASK, "C", NULL);
-Index: Mesa-7.10.2/src/glsl/strtod.c
-===================================================================
---- Mesa-7.10.2.orig/src/glsl/strtod.c 2011-01-03 16:45:51.000000000 -0800
-+++ Mesa-7.10.2/src/glsl/strtod.c 2011-07-20 19:10:21.441785488 -0700
-@@ -44,7 +44,7 @@
- double
- glsl_strtod(const char *s, char **end)
- {
--#if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__)
-+#if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__) && defined (HAVE_NEWLOCALE)
- static locale_t loc = NULL;
- if (!loc) {
- loc = newlocale(LC_CTYPE_MASK, "C", NULL);
-Index: Mesa-7.10.2/configure.ac
-===================================================================
---- Mesa-7.10.2.orig/configure.ac 2011-07-20 19:09:02.000000000 -0700
-+++ Mesa-7.10.2/configure.ac 2011-07-20 19:09:57.121785492 -0700
-@@ -450,6 +450,9 @@
- dnl See if posix_memalign is available
- AC_CHECK_FUNC([posix_memalign], [DEFINES="$DEFINES -DHAVE_POSIX_MEMALIGN"])
-
-+dnl See if newlocale is available
-+AC_CHECK_FUNCS_ONCE(newlocale)
-+
- dnl SELinux awareness.
- AC_ARG_ENABLE([selinux],
- [AS_HELP_STRING([--enable-selinux],