summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2012-08-02 17:49:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:45:09 +0100
commite4039eb74b20e96d4b8837cd58cf2d13d091e1ad (patch)
treee72989c8eb4b2f822418d718de5aa7c29924ac73 /meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch
parentbe882417cf432fe79a843cea4439503f286206cf (diff)
downloadopenembedded-core-e4039eb74b20e96d4b8837cd58cf2d13d091e1ad.tar.gz
mesa: Update to 8.0.4 (latest stable version)
- The license file has changed, but the project still has the same license - Patches have been rebased on top of the 8.0 branch. crossfix.patch and crossfix-mklib.patch have been merged as they address the same problem Signed-off-by: Damien Lespiau <damien.lespiau@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch')
-rw-r--r--meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch b/meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch
new file mode 100644
index 0000000000..d39270a48b
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa/0001-Compile-with-uclibc.patch
@@ -0,0 +1,52 @@
+Compile with uclibc
+
+Upstream-Status: Pending
+---
+ configure.ac | 3 +++
+ src/glsl/strtod.c | 2 +-
+ src/mesa/main/imports.c | 2 +-
+ 3 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index fbaa376..454dad2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -543,6 +543,9 @@ AC_SUBST([DLOPEN_LIBS])
+ dnl See if posix_memalign is available
+ AC_CHECK_FUNC([posix_memalign], [DEFINES="$DEFINES -DHAVE_POSIX_MEMALIGN"])
+
++dnl See if newlocale is available
++AC_CHECK_FUNCS_ONCE(newlocale)
++
+ dnl SELinux awareness.
+ AC_ARG_ENABLE([selinux],
+ [AS_HELP_STRING([--enable-selinux],
+diff --git a/src/glsl/strtod.c b/src/glsl/strtod.c
+index a876e13..9fce7e9 100644
+--- a/src/glsl/strtod.c
++++ b/src/glsl/strtod.c
+@@ -45,7 +45,7 @@ double
+ glsl_strtod(const char *s, char **end)
+ {
+ #if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__) && \
+- !defined(__HAIKU__)
++ !defined(__HAIKU__) && defined (HAVE_NEWLOCALE)
+ static locale_t loc = NULL;
+ if (!loc) {
+ loc = newlocale(LC_CTYPE_MASK, "C", NULL);
+diff --git a/src/mesa/main/imports.c b/src/mesa/main/imports.c
+index d3727ef..363bf32 100644
+--- a/src/mesa/main/imports.c
++++ b/src/mesa/main/imports.c
+@@ -767,7 +767,7 @@ float
+ _mesa_strtof( const char *s, char **end )
+ {
+ #if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__) && \
+- !defined(ANDROID) && !defined(__HAIKU__)
++ !defined(ANDROID) && !defined(__HAIKU__) && defined (HAVE_NEWLOCALE)
+ static locale_t loc = NULL;
+ if (!loc) {
+ loc = newlocale(LC_CTYPE_MASK, "C", NULL);
+--
+1.7.10.4
+