summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-23 23:20:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-23 23:23:21 +0000
commitb7b45faaf1246bef262a65d033aa1daa3219e318 (patch)
tree6f34deb424e599c74e8e333720b51eba6dbfb53b /meta/recipes-gnome
parent7d24d476e03f88bf47385f7a85ceb7c82662ed76 (diff)
downloadopenembedded-core-b7b45faaf1246bef262a65d033aa1daa3219e318.tar.gz
gobject-introspection: Fix sysroot postinst scripting error
Clearly the echo into ld.so.conf doesn't make sense and there was a cut and paste error when writing this code. As long as the directory existed, the builds worked so it created a race. Fix it as people hit build failures. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gobject-introspection/gobject-introspection_1.50.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.50.0.bb b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.50.0.bb
index 15c8c00f0a..509fc5fa59 100644
--- a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.50.0.bb
+++ b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.50.0.bb
@@ -171,7 +171,7 @@ gi_ldsoconf_sysroot_preprocess () {
mkdir -p ${SYSROOT_DESTDIR}${bindir}
dest=${SYSROOT_DESTDIR}${bindir}/postinst-ldsoconf-${PN}
echo "#!/bin/sh" > $dest
- echo "echo mkdir -p ${STAGING_DIR_TARGET}${sysconfdir} > ${STAGING_DIR_TARGET}${sysconfdir}/ld.so.conf" >> $dest
+ echo "mkdir -p ${STAGING_DIR_TARGET}${sysconfdir}" >> $dest
echo "echo ${base_libdir} >> ${STAGING_DIR_TARGET}${sysconfdir}/ld.so.conf" >> $dest
echo "echo ${libdir} >> ${STAGING_DIR_TARGET}${sysconfdir}/ld.so.conf" >> $dest
chmod 755 $dest