summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-28 21:59:05 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-06 14:38:07 +0100
commit8d3bd6fbf748ad6f67bb2e86854d15f99a07bf87 (patch)
tree364766a2942302bd89b6466e8c19dc0ba1eb9afe /meta/recipes-gnome
parent03b068881cc22d40c63bb23405b37ce9277460f1 (diff)
downloadopenembedded-core-8d3bd6fbf748ad6f67bb2e86854d15f99a07bf87.tar.gz
epiphany: Fix build errors when compiling with security flags
We need to have some level of optimization level for FORTIFY_SOURCE to work therefore set --enable-debug=no Add a patch to fix build error due to unused result of fread Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/epiphany/epiphany_3.24.2.bb6
-rw-r--r--meta/recipes-gnome/epiphany/files/0001-bookmarks-Check-for-return-value-of-fread.patch32
2 files changed, 36 insertions, 2 deletions
diff --git a/meta/recipes-gnome/epiphany/epiphany_3.24.2.bb b/meta/recipes-gnome/epiphany/epiphany_3.24.2.bb
index 77c19331cb..dafad8a793 100644
--- a/meta/recipes-gnome/epiphany/epiphany_3.24.2.bb
+++ b/meta/recipes-gnome/epiphany/epiphany_3.24.2.bb
@@ -9,11 +9,13 @@ DEPENDS = "libsoup-2.4 webkitgtk gtk+3 iso-codes avahi libnotify gcr \
inherit gnomebase gsettings distro_features_check upstream-version-is-even gettext
REQUIRED_DISTRO_FEATURES = "x11"
-SRC_URI += "file://0001-yelp.m4-drop-the-check-for-itstool.patch"
+SRC_URI += "file://0001-yelp.m4-drop-the-check-for-itstool.patch \
+ file://0001-bookmarks-Check-for-return-value-of-fread.patch \
+ "
SRC_URI[archive.md5sum] = "e035dc6f64f0c1909de823e03f16b2f3"
SRC_URI[archive.sha256sum] = "5abc0d0c60591df5236ac9b8979dc9f7d9acbb8ad0902b4772d2b7beea81c58d"
-EXTRA_OECONF += " --with-distributor-name=${DISTRO}"
+EXTRA_OECONF += " --with-distributor-name=${DISTRO} --enable-debug=no"
do_configure_prepend() {
sed -i -e s:help::g ${S}/Makefile.am
diff --git a/meta/recipes-gnome/epiphany/files/0001-bookmarks-Check-for-return-value-of-fread.patch b/meta/recipes-gnome/epiphany/files/0001-bookmarks-Check-for-return-value-of-fread.patch
new file mode 100644
index 0000000000..ddcd39400c
--- /dev/null
+++ b/meta/recipes-gnome/epiphany/files/0001-bookmarks-Check-for-return-value-of-fread.patch
@@ -0,0 +1,32 @@
+From aa2176be32eed2578da82f34d31148f934c11c34 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 28 Jun 2017 17:03:45 -0700
+Subject: [PATCH] bookmarks: Check for return value of fread()
+
+Fixes below compiler error
+ignoring return value of 'fread', declared with attribute warn_unused_result
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/bookmarks/ephy-bookmark.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/bookmarks/ephy-bookmark.c b/src/bookmarks/ephy-bookmark.c
+index ff0239b..8633ce4 100644
+--- a/src/bookmarks/ephy-bookmark.c
++++ b/src/bookmarks/ephy-bookmark.c
+@@ -217,7 +217,8 @@ ephy_bookmark_init (EphyBookmark *self)
+ bytes = g_malloc (num_bytes);
+
+ fp = fopen ("/dev/urandom", "r");
+- fread (bytes, sizeof (guint8), num_bytes, fp);
++ if (fread (bytes, sizeof (guint8), num_bytes, fp) != num_bytes)
++ g_warning("Unable to read data from /dev/urandom\n");
+
+ self->id = g_malloc0 (ID_LEN + 1);
+ for (gsize i = 0; i < num_bytes; i++) {
+--
+2.13.2
+