summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-17 10:08:53 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-05 12:35:42 +0000
commit0f485bfd6fc82a109b9da629e464fca1e90faec3 (patch)
tree1606c51c99e069d303a0210fcef518b5fdc482cf /meta/recipes-gnome
parent0c97fd9d721cea9786e89a557418649ef4576cfd (diff)
downloadopenembedded-core-0f485bfd6fc82a109b9da629e464fca1e90faec3.tar.gz
native.bbclass: Fix variable remapping coverage
When looking for RDEPENDS to process, bitbake iterates through PACKAGES *and* PN. Since native.bbclass sets PACKAGES to be empty, its pointless remapping the list of PACKAGES since this does nothing. There is a problem since *_${PN} are used by bitbake but not remapped by the native.bbclass class extension code. This changes the code to remap _${PN} in both expanded and unexpanded forms. As a result of this, various surprising dependencies are uncovered and the patch rectifies those. These are real bugs since they're injecting unneeded (unremapped) dependencies into the dependency chain. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gnome/gconf_3.2.3.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gconf_3.2.3.bb b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
index 9d327fce85..f7d35946d3 100644
--- a/meta/recipes-gnome/gnome/gconf_3.2.3.bb
+++ b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
@@ -39,6 +39,7 @@ do_install_append() {
# disable dbus-x11 when x11 isn't in DISTRO_FEATURES
RDEPENDS_${PN} += "${@base_contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)}"
+RDEPENDS_${PN}_virtclass-native = ""
FILES_${PN} += "${libdir}/GConf/* \
${libdir}/gio/*/*.so \