aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2017-10-24 14:04:09 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-04 17:14:28 +0000
commit60584b9047d844d6e5394338c133e8dab954e09d (patch)
tree066d7f0315d15433a8fab3e171ad08e815611a43 /meta/recipes-gnome
parent8bf0e3ee85b22fdd4d8940878b4d99cccff1efd5 (diff)
downloadopenembedded-core-60584b9047d844d6e5394338c133e8dab954e09d.tar.gz
gobject-introspection: improve reproducibility
Remove cross-compiler wrappers from the package, these contain numerous build host references. The wrappers are only needed for cross-compiling. [YOCTO #11705] Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Armin Kuster <akuster@mvista.com>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gobject-introspection/gobject-introspection_1.52.1.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.52.1.bb b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.52.1.bb
index 605f02eb0e..3fe71a3896 100644
--- a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.52.1.bb
+++ b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.52.1.bb
@@ -177,3 +177,12 @@ gi_ldsoconf_sysroot_preprocess () {
echo "echo ${libdir} >> ${STAGING_DIR_TARGET}${sysconfdir}/ld.so.conf" >> $dest
chmod 755 $dest
}
+
+# Remove wrapper files from the package, only used for cross-compiling
+PACKAGE_PREPROCESS_FUNCS += "gi_package_preprocess"
+gi_package_preprocess() {
+ rm -f ${PKGD}${bindir}/g-ir-scanner-qemuwrapper
+ rm -f ${PKGD}${bindir}/g-ir-scanner-wrapper
+ rm -f ${PKGD}${bindir}/g-ir-compiler-wrapper
+ rm -f ${PKGD}${bindir}/g-ir-scanner-lddwrapper
+}