summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gnome-icon-theme
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-10-20 22:25:22 +0100
committerJoshua Lock <josh@linux.intel.com>2010-10-20 22:30:01 +0100
commit27d06858b5f3138039bddecc0eaaee1e05e21b48 (patch)
treec6461c55ae39e9c991e665ab406d1369563cff82 /meta/recipes-gnome/gnome/gnome-icon-theme
parent980e0cec49edbfa2fceb5b3398cc3c52b30448cc (diff)
downloadopenembedded-core-27d06858b5f3138039bddecc0eaaee1e05e21b48.tar.gz
gnome-icon-theme: fix build
Duplicate the patch from sato-icon-theme which enables the path to the icon-name-mapping tool to be specified. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/recipes-gnome/gnome/gnome-icon-theme')
-rw-r--r--meta/recipes-gnome/gnome/gnome-icon-theme/iconpath-option.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gnome-icon-theme/iconpath-option.patch b/meta/recipes-gnome/gnome/gnome-icon-theme/iconpath-option.patch
new file mode 100644
index 0000000000..935b358f9f
--- /dev/null
+++ b/meta/recipes-gnome/gnome/gnome-icon-theme/iconpath-option.patch
@@ -0,0 +1,51 @@
+Version of the patch of the same name from sato-icon-theme JL - 20/10/10
+"
+pkg-config will only search the target sysroot and we want the native script. This
+patch adds an option to allow the path to the tool to be specified.
+
+RP - 12/8/10"
+Index: gnome-icon-theme-2.22.0/configure.in
+===================================================================
+--- gnome-icon-theme-2.22.0.orig/configure.in
++++ gnome-icon-theme-2.22.0/configure.in
+@@ -28,20 +28,28 @@ AC_SUBST(themedir, "\${datadir}/icons/gn
+
+ UTILS_REQUIRED=0.8.1
+
+-AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
+-PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED,
+- have_utils=yes, have_utils=no)
+-if test "x$have_utils" = "xyes"; then
+- UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
+- ICONMAP="$UTILS_PATH/icon-name-mapping"
+- AC_SUBST(ICONMAP)
+- AC_MSG_RESULT([yes])
+-else
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build
+- and install gnome-icon-theme])
++PKG_PROG_PKG_CONFIG()
++
++AC_ARG_WITH(iconmap,
++ AC_HELP_STRING([--with-iconmap=<dir>], [The location of the icon-name-mapping script to use]),
++ ICONMAP=$withval, ICONMAP="")
++if test "x$ICONMAP" = "x"; then
++ AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
++ PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED,
++ have_utils=yes, have_utils=no)
++ if test "x$have_utils" = "xyes"; then
++ UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
++ ICONMAP="$UTILS_PATH/icon-name-mapping"
++
++ AC_MSG_RESULT([yes])
++ else
++ AC_MSG_RESULT([no])
++ AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build and install sato-icon-theme"])
++ fi
+ fi
+
++AC_SUBST(ICONMAP)
++
+ AC_CONFIG_FILES([
+ Makefile
+ gnome-icon-theme.pc