summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-06-11 13:18:53 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-12 11:02:08 +0100
commitbf94103d4c532ffdfdcdcc6d27c9f65f7824f8f8 (patch)
tree06d74c69dbfa89dde701ab41fa211a2a1530d152 /meta/recipes-extended
parentc5898ef3fc3820ff9c44bc5b1b16e5def64aa877 (diff)
downloadopenembedded-core-bf94103d4c532ffdfdcdcc6d27c9f65f7824f8f8.tar.gz
rpm: Upgrade RPM to 5.4.9
Beside upreving RPM, add necessary integration patches to libzypp. Also change the configuration of RPM to support PACKAGECONFIG flags. RPM is highly configurable, the default configuration is good for minimal OE-Core use. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libzypp/libzypp/libzypp-rpm549.patch28
-rw-r--r--meta/recipes-extended/libzypp/libzypp_git.bb3
2 files changed, 30 insertions, 1 deletions
diff --git a/meta/recipes-extended/libzypp/libzypp/libzypp-rpm549.patch b/meta/recipes-extended/libzypp/libzypp/libzypp-rpm549.patch
new file mode 100644
index 0000000000..8268a2d51d
--- /dev/null
+++ b/meta/recipes-extended/libzypp/libzypp/libzypp-rpm549.patch
@@ -0,0 +1,28 @@
+commit 6c47ad415246cc3a3edac2e1637106d330574c85
+Author: Mark Hatle <mark.hatle@windriver.com>
+Date: Fri May 11 19:05:09 2012 -0500
+
+ RpmHeader.cc: RPM 5.4.9 integration
+
+ _RPMVSF_xxx - NODIGEST, NOSIGNATURES, NOHEADER, and NOPAYLOAD
+ are now obsolete and no longer supported.
+
+ Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff --git a/zypp/target/rpm/RpmHeader.cc b/zypp/target/rpm/RpmHeader.cc
+index 1224ecd..c96dae6 100644
+--- a/zypp/target/rpm/RpmHeader.cc
++++ b/zypp/target/rpm/RpmHeader.cc
+@@ -230,10 +230,12 @@ RpmHeader::constPtr RpmHeader::readPackage( const Pathname & path_r,
+ librpmDb::globalInit();
+ rpmts ts = ::rpmtsCreate();
+ unsigned vsflag = RPMVSF_DEFAULT;
++#if !defined(_RPM_5)
+ if ( verification_r & NODIGEST )
+ vsflag |= _RPMVSF_NODIGESTS;
+ if ( verification_r & NOSIGNATURE )
+ vsflag |= _RPMVSF_NOSIGNATURES;
++#endif
+ ::rpmtsSetVSFlags( ts, rpmVSFlags(vsflag) );
+
+ Header nh = 0;
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
index 3c3a9f09ec..c5761d5784 100644
--- a/meta/recipes-extended/libzypp/libzypp_git.bb
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -11,7 +11,7 @@ DEPENDS = "rpm boost curl libxml2 zlib sat-solver expat openssl udev libproxy"
S = "${WORKDIR}/git"
SRCREV = "15b6c52260bbc52b3d8e585e271b67e10cc7c433"
PV = "0.0-git${SRCPV}"
-PR = "r20"
+PR = "r21"
SRC_URI = "git://github.com/openSUSE/libzypp.git;protocol=git \
file://no-doc.patch \
@@ -23,6 +23,7 @@ SRC_URI = "git://github.com/openSUSE/libzypp.git;protocol=git \
file://fix_for_compile_wth_gcc-4.6.0.patch \
file://hardcode-lib-fix.patch \
file://close.patch \
+ file://libzypp-rpm549.patch \
"
SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch"