summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2018-10-05 12:05:17 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-09 12:02:41 +0100
commit99b74d1ff23ef91c84dc81ecf6437ad3bc37fb64 (patch)
tree206d1624ee8ef794072690d16c1b4413fcc887c9 /meta/recipes-extended
parent2f9f02d5fda9884ccf9ae22ceb00d59b99036a49 (diff)
downloadopenembedded-core-99b74d1ff23ef91c84dc81ecf6437ad3bc37fb64.tar.gz
parted: use update-alternatives for partprobe
busybox may also provide a partprobe implementation, so use u-a to allow installing them side by side. If one installs both, busybox and parted, one gets the following error: | ERROR: image do_rootfs: Postinstall scriptlets of ['busybox'] have failed. If the intention is to defer them to first boot, | then please place them into pkg_postinst_ontarget_${PN} (). | Deferring to first boot via 'exit 1' is no longer supported. And the coresponding log.do_rootfs extract: | ... | update-alternatives: Error: not linking ...image/rootfs/usr/sbin/partprobe to /bin/busybox.nosuid since ...image/rootfs/usr/sbin/partprobe exists and is not a link | ... Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/parted/parted_3.2.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-extended/parted/parted_3.2.bb b/meta/recipes-extended/parted/parted_3.2.bb
index ab30108bf2..6189fd2246 100644
--- a/meta/recipes-extended/parted/parted_3.2.bb
+++ b/meta/recipes-extended/parted/parted_3.2.bb
@@ -48,3 +48,9 @@ do_install_ptest() {
}
RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3"
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "partprobe"
+ALTERNATIVE_LINK_NAME[partprobe] = "${sbindir}/partprobe"