summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-01-05 16:39:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-09 11:45:20 +0000
commit93fe0f5044d30407c9afc69cbb570a82b6c82e5d (patch)
treed2fb09422c2a49c3f8a33f108338b2ee2964ea33 /meta/recipes-extended
parente9dfe7eb7f61b909ae7d034e80cfbebc1fad018b (diff)
downloadopenembedded-core-93fe0f5044d30407c9afc69cbb570a82b6c82e5d.tar.gz
psmisc: improve autopoint-enabling
Instead of globally clearing EXTRA_AUTORECONF (which by default currently contains --exclude=autopoint) use _remove to selectively remove the piece we care about. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/psmisc/psmisc.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/psmisc/psmisc.inc b/meta/recipes-extended/psmisc/psmisc.inc
index 527a1d590f..82ef947709 100644
--- a/meta/recipes-extended/psmisc/psmisc.inc
+++ b/meta/recipes-extended/psmisc/psmisc.inc
@@ -18,8 +18,8 @@ inherit autotools gettext
# Upstream has a custom autogen.sh which invokes po/update-potfiles as they
# don't ship a po/POTFILES.in (which is silly). Without that file gettext
-#doesn't believe po/ is a gettext directory and won't generate po/Makefile.
-EXTRA_AUTORECONF=""
+# doesn't believe po/ is a gettext directory and won't generate po/Makefile.
+EXTRA_AUTORECONF_remove = "--exclude=autopoint"
do_configure_prepend() {
( cd ${S} && po/update-potfiles )
}