summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorOoi Cinly <cinly.ooi@intel.com>2017-09-14 17:35:48 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-21 09:23:59 +0100
commit752a8a02d52cf868d1c182672d6ceb3d455dfa1e (patch)
tree6f394dca707e8cc5003abaf8a5b39517c7fe445f /meta/recipes-extended
parent027f1782dfd85b47f34a4a9c8b62a22f57fece7e (diff)
downloadopenembedded-core-752a8a02d52cf868d1c182672d6ceb3d455dfa1e.tar.gz
bzip2: Create Makefile for run-ptest
To improve binary reproducibility, only the relevent part of the Makefile in bzip2-ptest package that run-ptest needs are copied to the destination directory. bzip2-ptest requires Makefile. The original Makefile contains references to build host. By copying only the relevent part, we avoid those references making their way into the target system Used Makefile.am as the source to extract the revelent part instead of Makefile as it is easier to parse than Makefile. A redundant command in do_install_ptest() that repeat the copying of Makefile that was already copied by Makefile's install-ptest step is removed because it now interfers with the creation of the new Makefile by make's install-ptest. [YOCTO #11596] Signed-off-by: Ooi Cinly <cinly.ooi@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am3
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.6.bb1
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am b/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
index 05d389fc7d..dcf64584d9 100644
--- a/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
+++ b/meta/recipes-extended/bzip2/bzip2-1.0.6/Makefile.am
@@ -48,7 +48,8 @@ runtest:
else echo "FAIL: sample3 decompress"; fi
install-ptest:
- cp $(srcdir)/Makefile $(DESTDIR)/
+ sed -n '/^runtest:/,/^install-ptest:/{/^install-ptest:/!p}' \
+ $(srcdir)/Makefile.am > $(DESTDIR)/Makefile
cp $(srcdir)/sample1.ref $(DESTDIR)/
cp $(srcdir)/sample2.ref $(DESTDIR)/
cp $(srcdir)/sample3.ref $(DESTDIR)/
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
index 0512a75990..de668d6d2b 100644
--- a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
@@ -34,7 +34,6 @@ ALTERNATIVE_${PN} = "bunzip2 bzcat"
EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}"
do_install_ptest () {
- cp -f ${B}/Makefile ${D}${PTEST_PATH}/Makefile
sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
}