summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2017-10-12 11:35:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-05 13:44:56 +0000
commit721159db811e0cf1b8dee21740abdb2e27e7ddde (patch)
tree32ef0da22ad9e628f9bb1886484cc7db7063b946 /meta/recipes-extended
parenta99947274de16d712cfa661d2d7386bf0e28a01d (diff)
downloadopenembedded-core-721159db811e0cf1b8dee21740abdb2e27e7ddde.tar.gz
libxml-namespacesupport-perl: upgrade to 1.12.9
Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.9.bb35
-rw-r--r--meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb23
2 files changed, 35 insertions, 23 deletions
diff --git a/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.9.bb b/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.9.bb
new file mode 100644
index 0000000000..a7d26ea38c
--- /dev/null
+++ b/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.9.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Perl module for supporting simple generic namespaces"
+HOMEPAGE = "http://veillard.com/XML/"
+DESCRIPTION = "XML::NamespaceSupport offers a simple way to process namespace-based XML names. \
+ It also helps maintain a prefix-to-namespace URI map, and provides a number of \
+ basic checks. "
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+PR = "r3"
+
+LIC_FILES_CHKSUM = "file://META.yml;beginline=22;endline=22;md5=9ca1a4a941496e7feedac72c4fb8b137"
+
+# the upstream project complicate a bit url generartion on point release, using a underscore
+# instead of a point on URL, i.e 1.12_9 instead of 1.12.9
+python () {
+ baseurl = "http://search.cpan.org/CPAN/authors/id/P/PE/PERIGRIN/XML-NamespaceSupport"
+ pv = d.getVar('PV')
+ pvsplit = pv.split('.')
+
+ if len(pvsplit) != 3:
+ d.setVar('SRC_URI', "%s-%s.tar.gz" % (baseurl, pv))
+ d.setVar('S', "${WORKDIR}/XML-NamespaceSupport-${PV}")
+ else:
+ pvx, pvy, pvz = pvsplit
+ d.setVar('SRC_URI', "%s-%s.%s_%s.tar.gz" % (baseurl, pvx, pvy, pvz))
+ d.setVar('S', "${WORKDIR}/XML-NamespaceSupport-%s.%s_%s" % (pvx, pvy, pvz))
+}
+
+SRC_URI[md5sum] = "165927a311fb640961b28607035beab8"
+SRC_URI[sha256sum] = "2e84a057f0a8c845a612d212742cb94fca4fc8a433150b5721bd448f77d1e4a9"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
+
diff --git a/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb b/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb
deleted file mode 100644
index 3498a286d4..0000000000
--- a/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-SUMMARY = "Perl module for supporting simple generic namespaces"
-HOMEPAGE = "http://veillard.com/XML/"
-DESCRIPTION = "XML::NamespaceSupport offers a simple way to process namespace-based XML names. \
- It also helps maintain a prefix-to-namespace URI map, and provides a number of \
- basic checks. "
-
-SECTION = "libs"
-LICENSE = "Artistic-1.0 | GPL-1.0+"
-PR = "r3"
-
-LIC_FILES_CHKSUM = "file://META.yml;beginline=22;endline=22;md5=9ca1a4a941496e7feedac72c4fb8b137"
-
-SRC_URI = "http://search.cpan.org/CPAN/authors/id/P/PE/PERIGRIN/XML-NamespaceSupport-${PV}.tar.gz"
-SRC_URI[md5sum] = "a8916c6d095bcf073e1108af02e78c97"
-SRC_URI[sha256sum] = "47e995859f8dd0413aa3f22d350c4a62da652e854267aa0586ae544ae2bae5ef"
-
-
-S = "${WORKDIR}/XML-NamespaceSupport-${PV}"
-
-inherit cpan
-
-BBCLASSEXTEND="native"
-