summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorLi Wang <li.wang@windriver.com>2018-05-25 10:48:13 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-29 21:06:03 +0100
commit66aa9f1424202a583acd168182ae13ea68e2ab15 (patch)
treec708acefc9758927a42a3267078b04052b3e8d39 /meta/recipes-extended
parent9e373fec2013c5b2f9297e8f88317628ba9b7dce (diff)
downloadopenembedded-core-66aa9f1424202a583acd168182ae13ea68e2ab15.tar.gz
gawk: fix command location in ptest script
* Correct the command location in ptest scripts such as update the line "#!/bin/awk -f" to "#!/usr/bin/awk -f" in the file /usr/lib64/gawk/ptest/test/fcall_exit2.awk belongs to package gawk-ptest and the line "#!/usr/local/bin/gawk -f" to "#!/usr/bin/gawk -f" in the file /usr/lib64/gawk/ptest/test/fnarydel.awk Signed-off-by: Li Wang <li.wang@windriver.com> Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/gawk/gawk_4.2.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-extended/gawk/gawk_4.2.1.bb b/meta/recipes-extended/gawk/gawk_4.2.1.bb
index 6b9935767b..9663752394 100644
--- a/meta/recipes-extended/gawk/gawk_4.2.1.bb
+++ b/meta/recipes-extended/gawk/gawk_4.2.1.bb
@@ -43,6 +43,8 @@ do_install_ptest() {
for i in `grep -vE "@|^$|#|Gt-dummy" ${S}/test/Maketests |awk -F: '{print $1}'` Maketests inclib.awk; \
do cp ${S}/test/$i* ${D}${PTEST_PATH}/test; \
done
+ sed -i -e 's|/usr/local/bin|${bindir}|g' \
+ -e 's|#!${base_bindir}/awk|#!${bindir}/awk|g' ${D}${PTEST_PATH}/test/*.awk
}
BBCLASSEXTEND = "native nativesdk"