summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2018-08-17 14:27:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-24 07:53:09 +0100
commit4b2c86ff0031effd4cfdb477f67bc213d39ae0fd (patch)
tree6a30de959a7183c4a0528642bd958cc5e7938803 /meta/recipes-extended
parent115a6dea664c9b18fd19b79659029afb52b1a660 (diff)
downloadopenembedded-core-4b2c86ff0031effd4cfdb477f67bc213d39ae0fd.tar.gz
mdadm: fix usrmerge install path
Update /lib to $nonarch_base_libdir to fix the below error when usrmerge enabled in DISTRO_FEATURES. ERROR: mdadm-4.0-r0 do_package_qa: QA Issue: mdadm package is not obeying usrmerge distro feature. /lib should be relocated to /usr. [usrmerge] Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_4.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.0.bb b/meta/recipes-extended/mdadm/mdadm_4.0.bb
index 226b974352..2c4d88a9e7 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.0.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.0.bb
@@ -42,7 +42,7 @@ CFLAGS_append_mipsarchn32 = ' -D__SANE_USERSPACE_TYPES__'
do_compile() {
# Point to right sbindir
- sed -i -e "s;BINDIR = /sbin;BINDIR = $base_sbindir;" ${S}/Makefile
+ sed -i -e "s;BINDIR = /sbin;BINDIR = $base_sbindir;" -e "s;UDEVDIR = /lib;UDEVDIR = $nonarch_base_libdir;" ${S}/Makefile
oe_runmake SYSROOT="${STAGING_DIR_TARGET}"
}