summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorMuhammad Shakeel <muhammad_shakeel@mentor.com>2012-12-05 20:02:10 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:30:37 +0000
commit3b41513a63df6636b617eff09ff1ea9574c5e6f0 (patch)
tree8d1b4fea97e8b1553dc2eef1b899a47e572225db /meta/recipes-extended
parent275ea500809e70ba2e432b950311678b2ff4aef6 (diff)
downloadopenembedded-core-3b41513a63df6636b617eff09ff1ea9574c5e6f0.tar.gz
zip: Remove QA warnings: No GNU_HASH in the elf binary
Update the LFLAGS1 in the Makefile to remove warnings: QA Issue: No GNU_HASH in the elf binary Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/zip/zip.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-extended/zip/zip.inc b/meta/recipes-extended/zip/zip.inc
index a3bbc934e0..265d9a8adb 100644
--- a/meta/recipes-extended/zip/zip.inc
+++ b/meta/recipes-extended/zip/zip.inc
@@ -12,6 +12,8 @@ EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
'BINFLAGS=0755' 'INSTALL_D=install -d'"
do_compile() {
+ oe_runmake -f unix/Makefile flags
+ sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
oe_runmake -f unix/Makefile generic
}