summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-08-13 17:43:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-14 11:36:22 +0100
commit2c480b363ae80dcc55ec0228f8af0311e023fbf4 (patch)
treed5e01d087f180d870c9766b57b4fadea26af2bac /meta/recipes-extended
parentfbb2df435140eafc3fe1ca7419398e3b5ef273c8 (diff)
downloadopenembedded-core-2c480b363ae80dcc55ec0228f8af0311e023fbf4.tar.gz
man-db: add volatile configuration file for sysvinit
Add volatile configuraiton file for man-db so that in sysvinit systems we don't get failure when running `mandb'. The error message is like below. mandb: can't create index cache /var/cache/man/579: No such file or directory [YOCTO #12872] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/man-db/files/99_mandb1
-rw-r--r--meta/recipes-extended/man-db/man-db_2.8.3.bb12
2 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-extended/man-db/files/99_mandb b/meta/recipes-extended/man-db/files/99_mandb
new file mode 100644
index 0000000000..9b8a1712b7
--- /dev/null
+++ b/meta/recipes-extended/man-db/files/99_mandb
@@ -0,0 +1 @@
+d man man 0755 /var/cache/man none
diff --git a/meta/recipes-extended/man-db/man-db_2.8.3.bb b/meta/recipes-extended/man-db/man-db_2.8.3.bb
index a214bd7dd1..e1a7ad9d1e 100644
--- a/meta/recipes-extended/man-db/man-db_2.8.3.bb
+++ b/meta/recipes-extended/man-db/man-db_2.8.3.bb
@@ -4,7 +4,8 @@ LICENSE = "LGPLv2.1 & GPLv2"
LIC_FILES_CHKSUM = "file://docs/COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
file://docs/COPYING;md5=eb723b61539feef013de476e68b5c50a"
-SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz"
+SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz \
+ file://99_mandb"
SRC_URI[md5sum] = "6f3055e18fdd1ce5cbbdb30403991ec7"
SRC_URI[sha256sum] = "5932a1ca366e1ec61a3ece1a3afa0e92f2fdc125b61d236f20cc6ff9d80cc4ac"
@@ -17,6 +18,15 @@ inherit gettext pkgconfig autotools
EXTRA_OECONF = "--with-pager=less"
+do_install() {
+ autotools_do_install
+
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
+ install -d ${D}/etc/default/volatiles
+ install -m 0644 ${WORKDIR}/99_mandb ${D}/etc/default/volatiles
+ fi
+}
+
do_install_append_libc-musl() {
rm -f ${D}${libdir}/charset.alias
}