summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorOleh Matiusha <omatiush@cisco.com>2024-04-03 08:53:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-04 14:02:24 +0100
commit9d749f0a67ce72952e7a731fe5081ae5f432dfdb (patch)
tree339e2ef968694faf4d118daf515f77c8a598e1ef /meta/recipes-extended
parent7d11e4d55c9de23edbf5ba21d7ee007bab20c38a (diff)
downloadopenembedded-core-9d749f0a67ce72952e7a731fe5081ae5f432dfdb.tar.gz
bash: improve reproducibility
nativesdk-bash package contains host references in output packages. remove them. Signed-off-by: Oleh Matiusha <omatiush@cisco.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/bash/bash.inc11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index 7832ad052b..e541161c75 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -74,7 +74,8 @@ do_install:append () {
mv ${D}${bindir}/bash ${D}${base_bindir}
fi
}
-do_install:append:class-target () {
+
+fix_absolute_paths () {
# Clean buildhost references in bashbug
sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
-e "s,-I${WORKDIR}/\S* ,,g" \
@@ -93,6 +94,14 @@ do_install:append:class-target () {
${D}${libdir}/bash/Makefile.inc
}
+do_install:append:class-target () {
+ fix_absolute_paths
+}
+
+do_install:append:class-nativesdk () {
+ fix_absolute_paths
+}
+
do_install_ptest () {
make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
cp ${B}/Makefile ${D}${PTEST_PATH}