aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-10-02 07:24:52 -0700
committerJoshua Lock <joshua.lock@collabora.co.uk>2015-11-20 15:46:26 +0000
commit6c32103a8491fb0a0fa5dec905720a40877c6563 (patch)
treebbbdf482dd475955719dda598100789b5aeea583 /meta/recipes-extended
parent513e52670ea52e8143f46777accf441bb5c299fa (diff)
downloadopenembedded-core-6c32103a8491fb0a0fa5dec905720a40877c6563.tar.gz
tzcode: update to 2015g
Changes affecting code localtime no longer mishandles America/Anchorage after 2037. (Thanks to Bradley White for reporting the bug.) On hosts with signed 32-bit time_t, localtime no longer mishandles Pacific/Fiji after 2038-01-16 14:00 UTC. The localtime module allows the variables 'timezone', 'daylight', and 'altzone' to be in common storage shared with other modules, and declares them in case the system <time.h> does not. (Problems reported by Kees Dekker.) On platforms with tm_zone, strftime.c now assumes it is not NULL. This simplifies the code and is consistent with zdump.c. (Problem reported by Christos Zoulas.) Changes affecting documentation The tzfile man page now documents that transition times denote the starts (not the ends) of the corresponding time periods. (Ambiguity reported by Bill Seymour.) (From OE-Core master rev: 7c9082ab1ae6f7810c7cffe137d7d232b03852f8) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joshua Lock <joshua.lock@collabora.co.uk>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2015d.bb11
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2015g.bb25
2 files changed, 25 insertions, 11 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2015d.bb b/meta/recipes-extended/tzcode/tzcode-native_2015d.bb
deleted file mode 100644
index 44a9f03096..0000000000
--- a/meta/recipes-extended/tzcode/tzcode-native_2015d.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-# note that we allow for us to use data later than our code version
-#
-SRC_URI =" ftp://ftp.iana.org/tz/releases/tzcode${PV}.tar.gz;name=tzcode \
- ftp://ftp.iana.org/tz/releases/tzdata2015d.tar.gz;name=tzdata"
-
-SRC_URI[tzcode.md5sum] = "4008a3abc025a398697b2587c48258b9"
-SRC_URI[tzcode.sha256sum] = "221af54ec5c42eaf0101159ffe1256a883d1c14c46228d42774c656a56317128"
-SRC_URI[tzdata.md5sum] = "b595bdc4474b8fc1a15cffc67c66025b"
-SRC_URI[tzdata.sha256sum] = "8b9f5008277f09e251e97dba7813f56168d691115bda90ade4638d72f296d531"
-
-require tzcode-native.inc
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2015g.bb b/meta/recipes-extended/tzcode/tzcode-native_2015g.bb
new file mode 100644
index 0000000000..989e24b311
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2015g.bb
@@ -0,0 +1,25 @@
+# note that we allow for us to use data later than our code version
+#
+DESCRIPTION = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD"
+
+LIC_FILES_CHKSUM = "file://${WORKDIR}/README;md5=d0ff93a73dd5bc3c6e724bb4343760f6"
+
+SRC_URI =" ftp://ftp.iana.org/tz/releases/tzcode${PV}.tar.gz;name=tzcode \
+ ftp://ftp.iana.org/tz/releases/tzdata2015g.tar.gz;name=tzdata"
+
+SRC_URI[tzcode.md5sum] = "a2c47d908a6426f530efb1393cf1cd06"
+SRC_URI[tzcode.sha256sum] = "18e402ef24bfad2ded38643c9a7a9a580f940a729cb47d983052fc28ff0c7ec4"
+SRC_URI[tzdata.md5sum] = "8d46e8b225b9a04c75f5c39636435ad6"
+SRC_URI[tzdata.sha256sum] = "b923cdbf078491696b17bc8d069c74bce73fabc5774629da2f410c9b31576161"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 755 zic ${D}${bindir}/
+ install -m 755 zdump ${D}${bindir}/
+ install -m 755 tzselect ${D}${bindir}/
+}