aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-02 21:04:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-03 16:45:04 +0100
commit2543b14dd0ca13005be0df027543431fc8e882ae (patch)
tree003ed12714ff59d4be59dcbf311d8cf1a73672fe /meta/recipes-extended
parent0ced649c055dd25c500d0fd34e4ea94504d98580 (diff)
downloadopenembedded-core-2543b14dd0ca13005be0df027543431fc8e882ae.tar.gz
recipes: Add missing pkgconfig class inherits
These recipes all use pkg-config in some way but were missing dependencies on the tool, this patch adds them. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/augeas/augeas.inc2
-rw-r--r--meta/recipes-extended/blktool/blktool_4-6.1.bb2
-rw-r--r--meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb2
-rw-r--r--meta/recipes-extended/iptables/iptables_1.4.21.bb2
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.1.2.bb2
-rw-r--r--meta/recipes-extended/libuser/libuser_0.60.bb2
-rw-r--r--meta/recipes-extended/minicom/minicom_2.7.bb2
-rw-r--r--meta/recipes-extended/msmtp/msmtp_1.4.32.bb2
-rw-r--r--meta/recipes-extended/rpcbind/rpcbind_0.2.1.bb2
9 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-extended/augeas/augeas.inc b/meta/recipes-extended/augeas/augeas.inc
index 61f81b084c..ac25326813 100644
--- a/meta/recipes-extended/augeas/augeas.inc
+++ b/meta/recipes-extended/augeas/augeas.inc
@@ -12,7 +12,7 @@ SRC_URI = "http://download.augeas.net/${BP}.tar.gz \
DEPENDS = "readline libxml2"
-inherit autotools
+inherit autotools pkgconfig
PACKAGES =+ "${PN}-lenses lib${BPN} lib${BPN}-dev lib${BPN}-staticdev lib${BPN}-dbg"
diff --git a/meta/recipes-extended/blktool/blktool_4-6.1.bb b/meta/recipes-extended/blktool/blktool_4-6.1.bb
index 8bd1bae650..69f2261b37 100644
--- a/meta/recipes-extended/blktool/blktool_4-6.1.bb
+++ b/meta/recipes-extended/blktool/blktool_4-6.1.bb
@@ -21,4 +21,4 @@ SRC_URI[patch.sha256sum] = "d7923527e1a00984620ab307c9047a653d7ae2856cd20a82de8a
S = "${WORKDIR}/${BPN}-4.orig"
-inherit autotools
+inherit autotools pkgconfig
diff --git a/meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb b/meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb
index c0290b1918..790c98138b 100644
--- a/meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb
+++ b/meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb
@@ -20,7 +20,7 @@ SRC_URI = "http://www.openprinting.org/download/foomatic/foomatic-filters-${PV}.
SRC_URI[md5sum] = "b05f5dcbfe359f198eef3df5b283d896"
SRC_URI[sha256sum] = "a2e2e53e502571e88eeb9010c45a0d54671f15707ee104f5c9c22b59ea7a33e3"
-inherit autotools
+inherit autotools pkgconfig
EXTRA_OECONF += "--disable-file-converter-check --with-file-converter=texttops"
diff --git a/meta/recipes-extended/iptables/iptables_1.4.21.bb b/meta/recipes-extended/iptables/iptables_1.4.21.bb
index 02bb8435dc..dc17d575dd 100644
--- a/meta/recipes-extended/iptables/iptables_1.4.21.bb
+++ b/meta/recipes-extended/iptables/iptables_1.4.21.bb
@@ -27,7 +27,7 @@ SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \
SRC_URI[md5sum] = "536d048c8e8eeebcd9757d0863ebb0c0"
SRC_URI[sha256sum] = "52004c68021da9a599feed27f65defcfb22128f7da2c0531c0f75de0f479d3e0"
-inherit autotools
+inherit autotools pkgconfig
EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR} \
"
diff --git a/meta/recipes-extended/libarchive/libarchive_3.1.2.bb b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
index c73ed35f6d..3e6cdb4a53 100644
--- a/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
+++ b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
@@ -34,6 +34,6 @@ SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz \
SRC_URI[md5sum] = "efad5a503f66329bb9d2f4308b5de98a"
SRC_URI[sha256sum] = "eb87eacd8fe49e8d90c8fdc189813023ccc319c5e752b01fb6ad0cc7b2c53d5e"
-inherit autotools-brokensep lib_package
+inherit autotools-brokensep lib_package pkgconfig
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-extended/libuser/libuser_0.60.bb b/meta/recipes-extended/libuser/libuser_0.60.bb
index ca608c7466..e6316ef488 100644
--- a/meta/recipes-extended/libuser/libuser_0.60.bb
+++ b/meta/recipes-extended/libuser/libuser_0.60.bb
@@ -19,7 +19,7 @@ SRC_URI[sha256sum] = "b1f73408ebfee79eb01a47c5879a2cdef6a00b75ee24870de7df1b816f
DEPENDS = "popt libpam glib-2.0 xz-native docbook-utils-native linuxdoc-tools-native python"
-inherit autotools gettext pythonnative python-dir
+inherit autotools gettext pythonnative python-dir pkgconfig
EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}"
diff --git a/meta/recipes-extended/minicom/minicom_2.7.bb b/meta/recipes-extended/minicom/minicom_2.7.bb
index 8b20ece80a..c002bc82d9 100644
--- a/meta/recipes-extended/minicom/minicom_2.7.bb
+++ b/meta/recipes-extended/minicom/minicom_2.7.bb
@@ -17,7 +17,7 @@ SRC_URI[sha256sum] = "9ac3a663b82f4f5df64114b4792b9926b536c85f59de0f2d2b321c7626
PACKAGECONFIG ??= ""
PACKAGECONFIG[lockdev] = "--enable-lockdev,--disable-lockdev,lockdev"
-inherit autotools gettext
+inherit autotools gettext pkgconfig
do_install() {
for d in doc extras man lib src; do make -C $d DESTDIR=${D} install; done
diff --git a/meta/recipes-extended/msmtp/msmtp_1.4.32.bb b/meta/recipes-extended/msmtp/msmtp_1.4.32.bb
index 1ef85477bd..4b7024ba85 100644
--- a/meta/recipes-extended/msmtp/msmtp_1.4.32.bb
+++ b/meta/recipes-extended/msmtp/msmtp_1.4.32.bb
@@ -15,7 +15,7 @@ SRC_URI = "http://sourceforge.net/projects/msmtp/files/msmtp/${PV}/${BPN}-${PV}.
SRC_URI[md5sum] = "aa60e22211118f222470439cea60f795"
SRC_URI[sha256sum] = "2bf0c5c7e78f9905f48de235a75111a1a88238793043bbeae00360b22f1a5f88"
-inherit gettext autotools update-alternatives
+inherit gettext autotools update-alternatives pkgconfig
EXTRA_OECONF += "--without-gnome-keyring --without-libidn"
diff --git a/meta/recipes-extended/rpcbind/rpcbind_0.2.1.bb b/meta/recipes-extended/rpcbind/rpcbind_0.2.1.bb
index 23219e01bd..89e567bfb2 100644
--- a/meta/recipes-extended/rpcbind/rpcbind_0.2.1.bb
+++ b/meta/recipes-extended/rpcbind/rpcbind_0.2.1.bb
@@ -26,7 +26,7 @@ UCLIBCPATCHES ?= ""
SRC_URI[md5sum] = "0a5f9c2142af814c55d957aaab3bcc68"
SRC_URI[sha256sum] = "da169ff877a5a07581fad50a9a808ac6e96f0c277a3df49a7ef005778428496e"
-inherit autotools update-rc.d systemd
+inherit autotools update-rc.d systemd pkgconfig
PACKAGECONFIG ??= "tcp-wrappers"
PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"