aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-27 18:01:44 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-28 14:00:21 +0000
commit006b8a7808a58713af16c326dc37d07765334b12 (patch)
tree7fb385008db2170db8de182851c26e1156944de1 /meta/recipes-extended
parent9d796611afc42bea5ad9cab47ba4fb5ac0cb5ddd (diff)
downloadopenembedded-core-006b8a7808a58713af16c326dc37d07765334b12.tar.gz
autotools-brokensep: Mark recipes with broken separate build dir support
This patch goes through the OE-Core recipes and marks those which use autotools but don't support a separate build directory (${S} != ${B}). A new class, autotools-brokensep is used for this purpose. This doesn't introduce any change in behaviour in its own right. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/at/at_3.1.14.bb2
-rw-r--r--meta/recipes-extended/bash/bash.inc2
-rw-r--r--meta/recipes-extended/bc/bc_1.06.bb2
-rw-r--r--meta/recipes-extended/cracklib/cracklib_2.9.1.bb2
-rw-r--r--meta/recipes-extended/cups/cups.inc2
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.07.bb2
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.1.2.bb2
-rw-r--r--meta/recipes-extended/ltp/ltp_20140115.bb2
-rw-r--r--meta/recipes-extended/mailx/mailx_12.5.bb2
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.3.bb2
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.14.bb2
-rw-r--r--meta/recipes-extended/procps/procps.inc2
-rw-r--r--meta/recipes-extended/quota/quota_4.01.bb2
-rw-r--r--meta/recipes-extended/slang/slang_2.2.4.bb2
-rw-r--r--meta/recipes-extended/sysstat/sysstat.inc2
-rw-r--r--meta/recipes-extended/xdg-utils/xdg-utils_1.1.0-rc1.bb2
16 files changed, 16 insertions, 16 deletions
diff --git a/meta/recipes-extended/at/at_3.1.14.bb b/meta/recipes-extended/at/at_3.1.14.bb
index 5207a0fc34..1b87d4ad41 100644
--- a/meta/recipes-extended/at/at_3.1.14.bb
+++ b/meta/recipes-extended/at/at_3.1.14.bb
@@ -39,7 +39,7 @@ EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
--with-atspool=/var/spool/at/spool \
ac_cv_header_security_pam_appl_h=${@base_contains('DISTRO_FEATURES', 'pam', 'yes', 'no', d)} "
-inherit autotools systemd
+inherit autotools-brokensep systemd
SYSTEMD_SERVICE_${PN} = "atd.service"
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index 9ccb390280..2bb2df9584 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -4,7 +4,7 @@ SECTION = "base/shell"
DEPENDS = "ncurses bison-native"
-inherit autotools gettext update-alternatives ptest
+inherit autotools-brokensep gettext update-alternatives ptest
PARALLEL_MAKE = ""
diff --git a/meta/recipes-extended/bc/bc_1.06.bb b/meta/recipes-extended/bc/bc_1.06.bb
index 055031829c..89d8bee667 100644
--- a/meta/recipes-extended/bc/bc_1.06.bb
+++ b/meta/recipes-extended/bc/bc_1.06.bb
@@ -18,7 +18,7 @@ SRC_URI = "${GNU_MIRROR}/bc/bc-${PV}.tar.gz \
SRC_URI[md5sum] = "d44b5dddebd8a7a7309aea6c36fda117"
SRC_URI[sha256sum] = "4ef6d9f17c3c0d92d8798e35666175ecd3d8efac4009d6457b5c99cea72c0e33"
-inherit autotools update-alternatives
+inherit autotools-brokensep update-alternatives
ALTERNATIVE_${PN} = "dc"
ALTERNATIVE_PRIORITY = "100"
diff --git a/meta/recipes-extended/cracklib/cracklib_2.9.1.bb b/meta/recipes-extended/cracklib/cracklib_2.9.1.bb
index b4354a4139..d70e76f43f 100644
--- a/meta/recipes-extended/cracklib/cracklib_2.9.1.bb
+++ b/meta/recipes-extended/cracklib/cracklib_2.9.1.bb
@@ -16,7 +16,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/cracklib/cracklib-${PV}.tar.gz \
SRC_URI[md5sum] = "90536219c520add2ceb3c26f0d7da404"
SRC_URI[sha256sum] = "408905c2539a97dc8cbbb6d7cd2046cb5647a345b4bda399220d9471be16d156"
-inherit autotools gettext
+inherit autotools-brokensep gettext
BBCLASSEXTEND = "native"
diff --git a/meta/recipes-extended/cups/cups.inc b/meta/recipes-extended/cups/cups.inc
index 7a18500530..e4771f7c80 100644
--- a/meta/recipes-extended/cups/cups.inc
+++ b/meta/recipes-extended/cups/cups.inc
@@ -12,7 +12,7 @@ SRC_URI = "http://www.cups.org/software/${PV}/${BP}-source.tar.bz2 \
LEAD_SONAME = "libcupsdriver.so"
-inherit autotools binconfig
+inherit autotools-brokensep binconfig
PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \
${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.07.bb b/meta/recipes-extended/ghostscript/ghostscript_9.07.bb
index 3ce9f1223a..64dc6f267f 100644
--- a/meta/recipes-extended/ghostscript/ghostscript_9.07.bb
+++ b/meta/recipes-extended/ghostscript/ghostscript_9.07.bb
@@ -54,7 +54,7 @@ EXTRA_OECONF_class-native = "--without-x --with-system-libtiff=no \
CFLAGS += "-DHAVE_SYS_TIME_H=1"
BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1"
-inherit autotools
+inherit autotools-brokensep
do_configure_prepend () {
mkdir -p obj
diff --git a/meta/recipes-extended/libarchive/libarchive_3.1.2.bb b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
index ffe0b2e673..2556dc8898 100644
--- a/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
+++ b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
@@ -31,6 +31,6 @@ SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz \
SRC_URI[md5sum] = "efad5a503f66329bb9d2f4308b5de98a"
SRC_URI[sha256sum] = "eb87eacd8fe49e8d90c8fdc189813023ccc319c5e752b01fb6ad0cc7b2c53d5e"
-inherit autotools lib_package
+inherit autotools-brokensep lib_package
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-extended/ltp/ltp_20140115.bb b/meta/recipes-extended/ltp/ltp_20140115.bb
index 2ab1d50a3e..361eccb0b1 100644
--- a/meta/recipes-extended/ltp/ltp_20140115.bb
+++ b/meta/recipes-extended/ltp/ltp_20140115.bb
@@ -30,7 +30,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
S = "${WORKDIR}/git"
-inherit autotools
+inherit autotools-brokensep
TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/meta/recipes-extended/mailx/mailx_12.5.bb b/meta/recipes-extended/mailx/mailx_12.5.bb
index a70f703aaf..cc0b6bfd3a 100644
--- a/meta/recipes-extended/mailx/mailx_12.5.bb
+++ b/meta/recipes-extended/mailx/mailx_12.5.bb
@@ -24,7 +24,7 @@ SRC_URI[patch.sha256sum] = "aaf2a4bbf145e5ca9cdeb0843091ec8cc01df6c9568c997207a5
S = "${WORKDIR}/heirloom-mailx-${PV}"
-inherit autotools
+inherit autotools-brokensep
CFLAGS_append = " -D_BSD_SOURCE -DDEBIAN -I${S}/EXT"
EXTRA_OEMAKE = "SENDMAIL=${sbindir}/sendmail"
diff --git a/meta/recipes-extended/mdadm/mdadm_3.3.bb b/meta/recipes-extended/mdadm/mdadm_3.3.bb
index 596b04ded8..5ef418e170 100644
--- a/meta/recipes-extended/mdadm/mdadm_3.3.bb
+++ b/meta/recipes-extended/mdadm/mdadm_3.3.bb
@@ -17,7 +17,7 @@ SRC_URI[sha256sum] = "9c07e518bdf3392ebac8874eb686258e10ea3ae0ff7a8acb6d014718a9
CFLAGS += "-fno-strict-aliasing"
-inherit autotools
+inherit autotools-brokensep
# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
do_configure_prepend () {
diff --git a/meta/recipes-extended/newt/libnewt_0.52.14.bb b/meta/recipes-extended/newt/libnewt_0.52.14.bb
index ee8206e4b4..65bcf40428 100644
--- a/meta/recipes-extended/newt/libnewt_0.52.14.bb
+++ b/meta/recipes-extended/newt/libnewt_0.52.14.bb
@@ -32,7 +32,7 @@ S = "${WORKDIR}/newt-${PV}"
EXTRA_OECONF = "--without-tcl --without-python"
-inherit autotools
+inherit autotools-brokensep
export STAGING_INCDIR
export STAGING_LIBDIR
diff --git a/meta/recipes-extended/procps/procps.inc b/meta/recipes-extended/procps/procps.inc
index 20d5fc2be2..da91da232d 100644
--- a/meta/recipes-extended/procps/procps.inc
+++ b/meta/recipes-extended/procps/procps.inc
@@ -13,7 +13,7 @@ DEPENDS = "ncurses"
SRC_URI = "http://procps.sourceforge.net/procps-${PV}.tar.gz \
file://install.patch"
-inherit autotools update-alternatives
+inherit autotools-brokensep update-alternatives
do_install_append() {
mv ${D}${bindir}/watch ${D}${bindir}/watch.${BPN}
diff --git a/meta/recipes-extended/quota/quota_4.01.bb b/meta/recipes-extended/quota/quota_4.01.bb
index d62834f43d..82f7899690 100644
--- a/meta/recipes-extended/quota/quota_4.01.bb
+++ b/meta/recipes-extended/quota/quota_4.01.bb
@@ -18,7 +18,7 @@ S = "${WORKDIR}/quota-tools"
DEPENDS = "gettext-native e2fsprogs"
-inherit autotools gettext pkgconfig
+inherit autotools-brokensep gettext pkgconfig
EXTRA_OEMAKE += 'STRIP=""'
diff --git a/meta/recipes-extended/slang/slang_2.2.4.bb b/meta/recipes-extended/slang/slang_2.2.4.bb
index db5c6334f2..90ed2d0a47 100644
--- a/meta/recipes-extended/slang/slang_2.2.4.bb
+++ b/meta/recipes-extended/slang/slang_2.2.4.bb
@@ -23,7 +23,7 @@ SRC_URI = "ftp://space.mit.edu/pub/davis/slang/v2.2/slang-${PV}.tar.bz2 \
file://sprintf-bug-concerning-8-bit-characters.patch \
"
-inherit autotools
+inherit autotools-brokensep
SRC_URI[md5sum] = "7fcfd447e378f07dd0c0bae671fe6487"
SRC_URI[sha256sum] = "9a8257a9a2a55099af858b13338dc8f3a06dd2069f46f0df2c9c3bb84a01d5db"
diff --git a/meta/recipes-extended/sysstat/sysstat.inc b/meta/recipes-extended/sysstat/sysstat.inc
index af1fa0c7cf..09a5d28d4a 100644
--- a/meta/recipes-extended/sysstat/sysstat.inc
+++ b/meta/recipes-extended/sysstat/sysstat.inc
@@ -8,7 +8,7 @@ SRC_URI = "http://pagesperso-orange.fr/sebastien.godard/sysstat-${PV}.tar.gz \
file://99_sysstat \
"
-inherit autotools gettext
+inherit autotools-brokensep gettext
EXTRA_OECONF += "--disable-sensors"
EXTRA_OEMAKE += 'LFLAGS=""'
diff --git a/meta/recipes-extended/xdg-utils/xdg-utils_1.1.0-rc1.bb b/meta/recipes-extended/xdg-utils/xdg-utils_1.1.0-rc1.bb
index f988b96e07..79698791bc 100644
--- a/meta/recipes-extended/xdg-utils/xdg-utils_1.1.0-rc1.bb
+++ b/meta/recipes-extended/xdg-utils/xdg-utils_1.1.0-rc1.bb
@@ -21,6 +21,6 @@ SRC_URI = "http://portland.freedesktop.org/download/${BPN}-${PV}.tar.gz"
SRC_URI[md5sum] = "fadf5e7a08e0526fc60dbe3e5b7ef8d6"
SRC_URI[sha256sum] = "7b05558ae4bb8ede356863cae8c42e3e012aa421bf9d45130a570fd209d79102"
-inherit autotools
+inherit autotools-brokensep
RDEPENDS_${PN} += "xprop"