summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-09-27 13:14:16 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-04 13:42:39 +0100
commitf8fe4ef09d6ab037928850bbb953e2b0a2da49e9 (patch)
treea0a473af4e2899ce93496548878b8bcd6658803a /meta/recipes-extended
parent7ea42eadf8aec734202b70ba2427230e63749d94 (diff)
downloadopenembedded-core-f8fe4ef09d6ab037928850bbb953e2b0a2da49e9.tar.gz
zypper & sat-solver: needs RDEPENDS on rpm-lib
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libzypp/libzypp_git.bb8
-rw-r--r--meta/recipes-extended/sat-solver/sat-solver_git.bb4
-rw-r--r--meta/recipes-extended/zypper/zypper_git.bb6
3 files changed, 11 insertions, 7 deletions
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
index 4b1b8e4b36..7d9382a0bf 100644
--- a/meta/recipes-extended/libzypp/libzypp_git.bb
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -8,13 +8,10 @@ inherit cmake gettext
DEPENDS = "rpm boost curl libxml2 zlib sat-solver expat openssl udev"
-# rpmdb2solv from sat-solver is run from libzypp
-RDEPENDS_${PN} = "sat-solver"
-
S = "${WORKDIR}/git"
SRCREV = "15b6c52260bbc52b3d8e585e271b67e10cc7c433"
PV = "0.0-git${SRCPV}"
-PR = "r14"
+PR = "r15"
SRC_URI = "git://github.com/openSUSE/libzypp.git;protocol=git \
file://no-doc.patch \
@@ -32,6 +29,9 @@ SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch"
# ARM specific global constructor workaround
SRC_URI_append_arm = " file://arm-workaround-global-constructor.patch"
+# rpmdb2solv from sat-solver is run from libzypp
+RDEPENDS_${PN} = "sat-solver rpm-libs"
+
PACKAGES =+ "${PN}-pkgmgt"
FILES_${PN} += "${libdir}/zypp ${datadir}/zypp ${datadir}/icons"
diff --git a/meta/recipes-extended/sat-solver/sat-solver_git.bb b/meta/recipes-extended/sat-solver/sat-solver_git.bb
index 0d9a439f91..b616c57552 100644
--- a/meta/recipes-extended/sat-solver/sat-solver_git.bb
+++ b/meta/recipes-extended/sat-solver/sat-solver_git.bb
@@ -8,7 +8,7 @@ DEPENDS = "libcheck rpm zlib expat db"
SRCREV = "0a7378d5f482f477a01cf1690d76871ab8bdcc32"
PV = "0.0-git${SRCPV}"
-PR = "r11"
+PR = "r12"
PARALLEL_MAKE=""
@@ -29,6 +29,8 @@ EXTRA_OECMAKE += " -DLIB=${@os.path.basename('${libdir}')}"
inherit cmake pkgconfig
+RDEPENDS_${PN} = "rpm-libs"
+
PACKAGE_ARCH = "${MACHINE_ARCH}"
do_archgen () {
diff --git a/meta/recipes-extended/zypper/zypper_git.bb b/meta/recipes-extended/zypper/zypper_git.bb
index 7f7ceb3024..4f4fc4dc8c 100644
--- a/meta/recipes-extended/zypper/zypper_git.bb
+++ b/meta/recipes-extended/zypper/zypper_git.bb
@@ -5,8 +5,7 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=3201406e350b39e05a82e28b5020f413"
DEPENDS = "libzypp augeas"
-RRECOMMENDS_${PN} = "procps util-linux-uuidgen"
-PR = "r5"
+PR = "r6"
SRCREV = "2c5bb6ceb99ecd950ef993e43d77bf0569ea0582"
inherit cmake
@@ -20,4 +19,7 @@ S = "${WORKDIR}/git"
PV = "1.5.3-git${SRCPV}"
+RDEPENDS_${PN} = "rpm-libs"
+RRECOMMENDS_${PN} = "procps util-linux-uuidgen"
+
PACKAGE_ARCH = "${MACHINE_ARCH}"