summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-09-13 16:10:24 -0700
committerSaul Wold <sgw@linux.intel.com>2011-09-13 16:19:30 -0700
commit3be290aac4da885fe5bc31797c4a689196c63b7a (patch)
treec2082d2c44651f42ff93158a0348a042b01ef27c /meta/recipes-extended
parentc7af358ec427487ccc053316d2f68f6121b97181 (diff)
downloadopenembedded-core-3be290aac4da885fe5bc31797c4a689196c63b7a.tar.gz
libzypp: move package-manger to it own package
[YOCTO #1234] This moves a couple of files to a pkgmgt package so that they will not be installed by default. This removes the Add/Remove Software Icon from rpm based rootfs. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libzypp/libzypp_git.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
index 1fc6809a35..aeae7dfd37 100644
--- a/meta/recipes-extended/libzypp/libzypp_git.bb
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -14,7 +14,7 @@ RDEPENDS_${PN} = "sat-solver"
S = "${WORKDIR}/git"
SRCREV = "15b6c52260bbc52b3d8e585e271b67e10cc7c433"
PV = "0.0-git${SRCPV}"
-PR = "r13"
+PR = "r14"
SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
file://no-doc.patch \
@@ -32,9 +32,16 @@ SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch"
# ARM specific global constructor workaround
SRC_URI_append_arm = " file://arm-workaround-global-constructor.patch"
+PACKAGES =+ "${PN}-pkgmgt"
+
FILES_${PN} += "${libdir}/zypp ${datadir}/zypp ${datadir}/icons"
FILES_${PN}-dev += "${datadir}/cmake"
+FILES_${PN}-pkgmgt = "${bindir}/package-manager \
+ ${bindir}/package-manager-su \
+ ${datadir}/applications/package-manager.desktop \
+ "
+
EXTRA_OECMAKE += " -DLIB=${@os.path.basename('${libdir}')}"
PACKAGE_ARCH = "${MACHINE_ARCH}"