summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorKumar Gala <galak@kernel.crashing.org>2011-07-28 13:09:50 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-01 13:57:53 +0100
commit09573a276456122b408c5bcebc537455fd1c5f29 (patch)
treedf85cda48f409e45158fe81213e3eded8ed09a8d /meta/recipes-extended
parent1d9866a2c4fe93202749a56c7ad89a3cbd07d9f8 (diff)
downloadopenembedded-core-09573a276456122b408c5bcebc537455fd1c5f29.tar.gz
libzypp: Fix variable substitution problem in do_archgen step
The do_archgen step creates a script that utilizes the variable name ${ARCH}. However, we also utilize and define ${ARCH} so instead of having the following in the script: COMPAT_WITH="${ARCH},${COMPAT} $COMPAT_WITH" We get something like: COMPAT_WITH="powerpc,${COMPAT} $COMPAT_WITH" Just renaming the variable in the script to not conflict with ${ARCH} fixes the issue. [PR bump from Saul Wold] Signed-off-by: Kumar Gala <galak@kernel.crashing.org> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libzypp/libzypp_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
index 6555bd4044..6e8fe16a15 100644
--- a/meta/recipes-extended/libzypp/libzypp_git.bb
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -14,7 +14,7 @@ RDEPENDS_${PN} = "sat-solver"
S = "${WORKDIR}/git"
SRCREV = "15b6c52260bbc52b3d8e585e271b67e10cc7c433"
PV = "0.0-git${SRCPV}"
-PR = "r11"
+PR = "r12"
SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
file://no-doc.patch \
@@ -111,9 +111,9 @@ do_archgen () {
shift ; continue;;
esac
if [ "${AVOID_CONSTRUCTOR}" != "true" ]; then
- ARCH="_$1"
+ CARCH="_$1"
else
- ARCH="IdString(\"$1\")"
+ CARCH="IdString(\"$1\")"
fi
shift
COMPAT=""
@@ -129,7 +129,7 @@ do_archgen () {
COMPAT="${arch_val},$COMPAT"
fi
done
- COMPAT_WITH="${ARCH},${COMPAT} $COMPAT_WITH"
+ COMPAT_WITH="${CARCH},${COMPAT} $COMPAT_WITH"
done
for each_compat in ${COMPAT_WITH} ; do
echo " defCompatibleWith( ${each_compat} );" >> zypp/poky-arch.h