aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/zip
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-02-12 05:42:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-02 12:54:36 +0000
commite93186642708cb99bfba776012e345c42e9bd0d5 (patch)
treebb94858e3b03dd50c3b8d3550fcec9e5f03132a4 /meta/recipes-extended/zip
parent8169adeba67180f062fa7c0105fc4283da3103c6 (diff)
downloadopenembedded-core-e93186642708cb99bfba776012e345c42e9bd0d5.tar.gz
zip: explictly disable bzip2 support
* we don't depends on bzip2, so make sure it's not autodetected in sysroot Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/zip')
-rw-r--r--meta/recipes-extended/zip/zip.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/zip/zip.inc b/meta/recipes-extended/zip/zip.inc
index 265d9a8adb..c73571ad54 100644
--- a/meta/recipes-extended/zip/zip.inc
+++ b/meta/recipes-extended/zip/zip.inc
@@ -12,9 +12,9 @@ EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
'BINFLAGS=0755' 'INSTALL_D=install -d'"
do_compile() {
- oe_runmake -f unix/Makefile flags
+ oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory
sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
- oe_runmake -f unix/Makefile generic
+ oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory
}
do_install() {