aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/wget
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2013-07-20 00:31:59 +1000
committerSaul Wold <sgw@linux.intel.com>2013-07-23 07:22:37 -0700
commitf0c89f4122a0df67a003a6721afb45d7979ffc6f (patch)
tree5b56f728460aff5512b0358c00c5c3b9e1286798 /meta/recipes-extended/wget
parent4b6deb521183b728d9a1c651d4805fe635e6cb50 (diff)
downloadopenembedded-core-f0c89f4122a0df67a003a6721afb45d7979ffc6f.tar.gz
wget: backport fixes for documentation build errors
Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/wget')
-rw-r--r--meta/recipes-extended/wget/wget-1.14/fix_doc.patch71
-rw-r--r--meta/recipes-extended/wget/wget_1.14.bb1
2 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-extended/wget/wget-1.14/fix_doc.patch b/meta/recipes-extended/wget/wget-1.14/fix_doc.patch
new file mode 100644
index 0000000000..91a5ff73da
--- /dev/null
+++ b/meta/recipes-extended/wget/wget-1.14/fix_doc.patch
@@ -0,0 +1,71 @@
+Fix documentation build errors with Texinfo 5 and Perl 5.18
+
+wget.pod around line 2105: Expected text after =item, not a number
+wget.pod around line 2110: Expected text after =item, not a number
+wget.pod around line 2116: Expected text after =item, not a number
+wget.pod around line 2121: Expected text after =item, not a number
+wget.pod around line 2126: Expected text after =item, not a number
+wget.pod around line 2131: Expected text after =item, not a number
+wget.pod around line 2136: Expected text after =item, not a number
+wget.pod around line 2141: Expected text after =item, not a number
+wget.texi:879: @itemx must follow @item
+wget.texi:980: @itemx must follow @item
+wget.texi:3097: @itemx must follow @item
+wget.texi:3608: warning: @itemx should not begin @table
+
+Upstream-Status: Backport
+Signed-off-by: Jonathan Liu <net147@gmail.com>
+
+diff --git a/doc/texi2pod.pl b/doc/texi2pod.pl
+index 86c4b18..9db6de1 100755
+--- a/doc/texi2pod.pl
++++ b/doc/texi2pod.pl
+@@ -291,7 +291,7 @@ while(<$inf>) {
+ if (defined $1) {
+ my $thing = $1;
+ if ($ic =~ /\@asis/) {
+- $_ = "\n=item $thing\n";
++ $_ = "\n=item C<$thing>\n";
+ } else {
+ # Entity escapes prevent munging by the <> processing below.
+ $_ = "\n=item $ic\&LT;$thing\&GT;\n";
+diff --git a/doc/wget.texi b/doc/wget.texi
+index 7efdc72..2b045fd 100644
+--- a/doc/wget.texi
++++ b/doc/wget.texi
+@@ -876,7 +876,7 @@ recommendation to block many unrelated users from a web site due to the
+ actions of one.
+
+ @cindex proxy
+-@itemx --no-proxy
++@item --no-proxy
+ Don't use proxies, even if the appropriate @code{*_proxy} environment
+ variable is defined.
+
+@@ -977,7 +977,7 @@ are outside the range of @sc{ascii} characters (that is, greater than
+ whose encoding does not match the one used locally.
+
+ @cindex IPv6
+-@itemx -4
++@item -4
+ @itemx --inet4-only
+ @itemx -6
+ @itemx --inet6-only
+@@ -3094,7 +3094,7 @@ display properly---the same as @samp{-p}.
+ Change setting of passive @sc{ftp}, equivalent to the
+ @samp{--passive-ftp} option.
+
+-@itemx password = @var{string}
++@item password = @var{string}
+ Specify password @var{string} for both @sc{ftp} and @sc{http} file retrieval.
+ This command can be overridden using the @samp{ftp_password} and
+ @samp{http_password} command for @sc{ftp} and @sc{http} respectively.
+@@ -3605,7 +3605,7 @@ In addition to the environment variables, proxy location and settings
+ may be specified from within Wget itself.
+
+ @table @samp
+-@itemx --no-proxy
++@item --no-proxy
+ @itemx proxy = on/off
+ This option and the corresponding command may be used to suppress the
+ use of proxy, even if the appropriate environment variables are set.
diff --git a/meta/recipes-extended/wget/wget_1.14.bb b/meta/recipes-extended/wget/wget_1.14.bb
index f26b884be6..b12c14711d 100644
--- a/meta/recipes-extended/wget/wget_1.14.bb
+++ b/meta/recipes-extended/wget/wget_1.14.bb
@@ -2,6 +2,7 @@ PR = "${INC_PR}.0"
SRC_URI = "${GNU_MIRROR}/wget/wget-${PV}.tar.gz \
file://fix_makefile.patch \
+ file://fix_doc.patch \
"
SRC_URI[md5sum] = "12edc291dba8127f2e9696e69f36299e"
SRC_URI[sha256sum] = "f3a6898e3a765bb94435b04a6668db9e5d19b3e90e0c69a503a2773ae936c269"