summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/watchdog/watchdog_5.15.bb
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-26 16:55:02 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-09 11:52:09 +0100
commit6864ad2e863205472f8ea2057c61e949dc450151 (patch)
treea6a8edbec84402971536f65287ebdd778b2b30fc /meta/recipes-extended/watchdog/watchdog_5.15.bb
parentb76af8a0982c3c7473bd6ba067d1c8030d4d2f26 (diff)
downloadopenembedded-core-6864ad2e863205472f8ea2057c61e949dc450151.tar.gz
watchdog-config: Add recipe
Provides configuration files for watchdog. Add watchdog-config as a runtime dependence of watchdog and remove watchdog.conf file from watchdog installation. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/watchdog/watchdog_5.15.bb')
-rw-r--r--meta/recipes-extended/watchdog/watchdog_5.15.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-extended/watchdog/watchdog_5.15.bb b/meta/recipes-extended/watchdog/watchdog_5.15.bb
index 1c0049c7af..cedfc042ce 100644
--- a/meta/recipes-extended/watchdog/watchdog_5.15.bb
+++ b/meta/recipes-extended/watchdog/watchdog_5.15.bb
@@ -40,6 +40,9 @@ INITSCRIPT_PARAMS_${PN}-keepalive = "start 15 1 2 3 4 5 . stop 85 0 6 ."
do_install_append() {
install -D ${S}/redhat/watchdog.init ${D}/${sysconfdir}/init.d/watchdog.sh
install -Dm 0755 ${WORKDIR}/wd_keepalive.init ${D}${sysconfdir}/init.d/wd_keepalive
+
+ # watchdog.conf is provided by the watchdog-config recipe
+ rm ${D}${sysconfdir}/watchdog.conf
}
PACKAGES =+ "${PN}-keepalive"
@@ -49,7 +52,8 @@ FILES_${PN}-keepalive = " \
${sbindir}/wd_keepalive \
"
-RDEPENDS_${PN} += "${PN}-keepalive"
+RDEPENDS_${PN} += "${PN}-config ${PN}-keepalive"
+RDEPENDS_${PN}-keepalive += "${PN}-config"
RRECOMMENDS_${PN} = "kernel-module-softdog"