summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/unzip
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2012-11-15 10:41:00 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-24 15:12:07 +0000
commit7f26794dc9f2e78ee8aed1e23752acb709345c6f (patch)
tree5b783a3fb50c7bab635f73678e67943f9e376e93 /meta/recipes-extended/unzip
parentdf2c260f9cda2e291c72f7debe1e6d53846ce058 (diff)
downloadopenembedded-core-7f26794dc9f2e78ee8aed1e23752acb709345c6f.tar.gz
unzip: pay some attention to our CFLAGS
Makefile makes use of CFLAGS_NOOPT. If we set that when calling make we can enable options like -g. The Makefile will override any optimization to -O3. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/unzip')
-rw-r--r--meta/recipes-extended/unzip/unzip_6.0.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-extended/unzip/unzip_6.0.bb b/meta/recipes-extended/unzip/unzip_6.0.bb
index a1547fc3b9..0f634c8cb9 100644
--- a/meta/recipes-extended/unzip/unzip_6.0.bb
+++ b/meta/recipes-extended/unzip/unzip_6.0.bb
@@ -4,7 +4,7 @@ SECTION = "console/utils"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=94caec5a51ef55ef711ee4e8b1c69e29"
PE = "1"
-PR = "r3"
+PR = "r4"
SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/unzip60.tgz \
file://avoid-strip.patch"
@@ -13,7 +13,12 @@ SRC_URI[md5sum] = "62b490407489521db863b523a7f86375"
SRC_URI[sha256sum] = "036d96991646d0449ed0aa952e4fbe21b476ce994abc276e49d30e686708bd37"
S = "${WORKDIR}/unzip60"
-EXTRA_OEMAKE += "STRIP=true LF2=''"
+# Makefile uses CF_NOOPT instead of CFLAGS. We lifted the values from
+# Makefile and add CFLAGS. Optimization will be overriden by unzip
+# configure to be -O3.
+#
+EXTRA_OEMAKE += "STRIP=true LF2='' \
+ 'CF_NOOPT=-I. -Ibzip2 -DUNIX ${CFLAGS}'"
export LD = "${CC}"
LD_class-native = "${CC}"