aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2013h.bb
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2013-10-28 14:23:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-29 10:33:59 +0000
commit95c9355c35d24b60f44857a8c2e3c9860a91d23b (patch)
treef27dd257c664e624f22ab9e0cb16faea66020624 /meta/recipes-extended/tzcode/tzcode-native_2013h.bb
parentfffa4c37c49b169f663d28612b9251819cef9577 (diff)
downloadopenembedded-core-95c9355c35d24b60f44857a8c2e3c9860a91d23b.tar.gz
tzcode & tzdata: update to 2013h
Update recipes to version 2013h of timezone code and data. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2013h.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2013h.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2013h.bb b/meta/recipes-extended/tzcode/tzcode-native_2013h.bb
new file mode 100644
index 0000000000..5cdc7efdff
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2013h.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD"
+
+LIC_FILES_CHKSUM = "file://${WORKDIR}/README;md5=0b7570113550eb5d30aa4bd220964b8f"
+
+# note that we allow for us to use data later than our code version
+#
+SRC_URI =" ftp://ftp.iana.org/tz/releases/tzcode${PV}.tar.gz;name=tzcode \
+ ftp://ftp.iana.org/tz/releases/tzdata2013h.tar.gz;name=tzdata"
+
+SRC_URI[tzdata.md5sum] = "d310abe42cbe87e76ceb69e2c7003c92"
+SRC_URI[tzdata.sha256sum] = "6b9e17e823eec0e09e12f74b452a70be4face1ef14c2fb1917b7c7e60564de27"
+
+SRC_URI[tzcode.md5sum] = "14250703b253e1cfdf97f1e928541508"
+SRC_URI[tzcode.sha256sum] = "e14addfc4e0da3cf17ccc1c08cb8094a2a0d3ae9524f565b74e6373c9b83ca0e"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 755 zic ${D}${bindir}/
+ install -m 755 zdump ${D}${bindir}/
+ install -m 755 tzselect ${D}${bindir}/
+}