aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sysklogd/files/no-vectorization.patch
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2011-09-28 23:21:09 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-29 16:54:03 +0100
commit5035097bb369dc1740b817734b92bcfa40d95d22 (patch)
tree98545b241c9884371f01b857319f76229ed7b3b4 /meta/recipes-extended/sysklogd/files/no-vectorization.patch
parent60b04097c7aeca2c4d529b2f23343a507fa68ea6 (diff)
downloadopenembedded-core-5035097bb369dc1740b817734b92bcfa40d95d22.tar.gz
Fix sysklogd build on e500v2 cores
Signed-off-by: Matthew McClintock <msm@freescale.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/sysklogd/files/no-vectorization.patch')
-rw-r--r--meta/recipes-extended/sysklogd/files/no-vectorization.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-extended/sysklogd/files/no-vectorization.patch b/meta/recipes-extended/sysklogd/files/no-vectorization.patch
new file mode 100644
index 0000000000..c1cc042c9c
--- /dev/null
+++ b/meta/recipes-extended/sysklogd/files/no-vectorization.patch
@@ -0,0 +1,20 @@
+Upstream-Status: Inappropriate
+
+The compiler should not be generating vectorized instructions on this target.
+This is a work around until I can determine why this is occuring on this
+particular recipe
+
+Index: sysklogd-1.5/Makefile
+===================================================================
+--- sysklogd-1.5.orig/Makefile
++++ sysklogd-1.5/Makefile
+@@ -20,7 +20,8 @@
+ CC= gcc
+ #SKFLAGS= -g -DSYSV -Wall
+ #LDFLAGS= -g
+-SKFLAGS= $(RPM_OPT_FLAGS) -O3 -DSYSV -fomit-frame-pointer -Wall -fno-strength-reduce
++SKFLAGS= $(RPM_OPT_FLAGS) -O3 -DSYSV -fomit-frame-pointer -Wall -fno-strength-reduce \
++ -fno-tree-vectorize
+ # -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+ # -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
+ # $(shell getconf LFS_SKFLAGS)