aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sudo
diff options
context:
space:
mode:
authorMihai Lindner <mihaix.lindner@linux.intel.com>2012-05-20 13:17:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-25 11:17:34 +0100
commit70562306a051ac93001851213441c9d5d6234517 (patch)
tree305f8afc28b22b7f6dfbb9ad2e26b3a0ad017f64 /meta/recipes-extended/sudo
parentf13aa28c879ac3e49b94d6fe1238f8b0db2a8666 (diff)
downloadopenembedded-core-70562306a051ac93001851213441c9d5d6234517.tar.gz
sudo: fixed wrong `chmod` path
Placed $D between braces ${D} to be correctly expanded to the workdir path, instead of a path relative to host rootfs. Currently, bitbake sudo fails on host systems where sudo is not installed. Signed-off-by: Mihai Lindner <mihaix.lindner@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/sudo')
-rw-r--r--meta/recipes-extended/sudo/sudo_1.8.4p4.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-extended/sudo/sudo_1.8.4p4.bb b/meta/recipes-extended/sudo/sudo_1.8.4p4.bb
index 23153223c7..20c4a14b3c 100644
--- a/meta/recipes-extended/sudo/sudo_1.8.4p4.bb
+++ b/meta/recipes-extended/sudo/sudo_1.8.4p4.bb
@@ -1,6 +1,6 @@
require sudo.inc
-PR = "r0"
+PR = "r1"
SRC_URI = "http://ftp.sudo.ws/sudo/dist/sudo-${PV}.tar.gz \
file://libtool.patch \
@@ -24,6 +24,6 @@ do_install_append () {
fi
done
- chmod 4111 $D/usr/bin/sudo
- chmod 0440 $D/etc/sudoers
+ chmod 4111 ${D}/usr/bin/sudo
+ chmod 0440 ${D}/etc/sudoers
}