aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sudo
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-11-09 17:04:08 -0600
committerSaul Wold <sgw@linux.intel.com>2011-11-11 00:33:50 -0800
commit463e44ae159da2e03369f9ac14843b479de2e43d (patch)
tree476793a6665f32aa8de483bd107c9928770e4e31 /meta/recipes-extended/sudo
parent662431ace246e9bb35ad8d0ddd0510193f93517d (diff)
downloadopenembedded-core-463e44ae159da2e03369f9ac14843b479de2e43d.tar.gz
sudo: Avoid post install scripts
The post install script was removed, and the install_append updated to ensure the permissions are set correctly. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-extended/sudo')
-rw-r--r--meta/recipes-extended/sudo/sudo.inc8
-rw-r--r--meta/recipes-extended/sudo/sudo_1.8.3.bb5
2 files changed, 4 insertions, 9 deletions
diff --git a/meta/recipes-extended/sudo/sudo.inc b/meta/recipes-extended/sudo/sudo.inc
index 72a7c167cd..83dd209afa 100644
--- a/meta/recipes-extended/sudo/sudo.inc
+++ b/meta/recipes-extended/sudo/sudo.inc
@@ -29,11 +29,3 @@ do_install_prepend (){
mkdir -p ${D}/${localstatedir}/lib
}
-pkg_postinst_${PN} () {
- if [ "x$D" != "x" ]; then
- exit 1
- fi
-
- chmod 4111 /usr/bin/sudo
- chmod 0440 /etc/sudoers
-}
diff --git a/meta/recipes-extended/sudo/sudo_1.8.3.bb b/meta/recipes-extended/sudo/sudo_1.8.3.bb
index 0ac0851153..99fe5b91e7 100644
--- a/meta/recipes-extended/sudo/sudo_1.8.3.bb
+++ b/meta/recipes-extended/sudo/sudo_1.8.3.bb
@@ -1,6 +1,6 @@
require sudo.inc
-PR = "r0"
+PR = "r1"
SRC_URI = "http://ftp.sudo.ws/sudo/dist/sudo-${PV}.tar.gz \
file://libtool.patch \
@@ -23,4 +23,7 @@ do_install_append () {
break
fi
done
+
+ chmod 4111 $D/usr/bin/sudo
+ chmod 0440 $D/etc/sudoers
}