aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/stat
diff options
context:
space:
mode:
authorShane Wang <shane.wang@intel.com>2012-01-11 19:38:07 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-17 14:52:58 +0000
commit99fdc0626d2e0f5a4a8fbaf0b1de86437966260f (patch)
tree30cd026f14264351705b24753c05e8eb3618536d /meta/recipes-extended/stat
parent3add06d4407b0a30ff8a8202aa028ab0cbfd28d6 (diff)
downloadopenembedded-core-99fdc0626d2e0f5a4a8fbaf0b1de86437966260f.tar.gz
stat: add recipe stat with version 3.3
stat is brought into Yocto because the latest version hdparm 9.37 depends on it, and add license checksum. The recipe was imported from the OpenEmbedded server (http://git.openembedded.org/openembedded/tree/recipes/stat) as of commit ids 709c4d66e0b107ca606941b988bad717c0b45d9b, 44985d56bc556786812a0a02d6219afd31a7381d, b3246d96069fd11caee42ec6ebcbf6dca2d62449. Signed-off-by: Shane Wang <shane.wang@intel.com>
Diffstat (limited to 'meta/recipes-extended/stat')
-rw-r--r--meta/recipes-extended/stat/stat_3.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-extended/stat/stat_3.3.bb b/meta/recipes-extended/stat/stat_3.3.bb
new file mode 100644
index 0000000000..0c387420d7
--- /dev/null
+++ b/meta/recipes-extended/stat/stat_3.3.bb
@@ -0,0 +1,26 @@
+SECTION = "console/utils"
+DESCRIPTION = "Display all information about a file that the stat() call provides and all information a filesystem that statfs() provides."
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=39886b077fd072e876e5c4c16310b631 \
+ file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+BBCLASSEXTEND = "native"
+
+PR = "r0"
+
+SRC_URI = "ftp://metalab.unc.edu/pub/Linux/utils/file/stat-3.3.tar.gz"
+SRC_URI[md5sum] = "37e247e8e400ad9205f1b0500b728fd3"
+SRC_URI[sha256sum] = "7071f0384a423a938dd542c1f08547a02824f6359acd3ef3f944b2c4c2d1ee09"
+
+do_install() {
+ install -d ${D}${bindir} ${D}${mandir}/man1
+ install -m 755 stat ${D}${bindir}
+ install -m 644 stat.1 ${D}${mandir}/man1
+}
+
+#do_install_virtclass-native() {
+# install -d ${D}${bindir}
+# install -m 755 stat ${D}${bindir}
+#}
+
+NATIVE_INSTALL_WORKS = "1"