aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/stat
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-06-13 10:48:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-14 08:41:53 +0100
commit2abc776393f8b5574dd9cf614ff1ae4b460e4d8c (patch)
tree0b8ea77163cf7c24a2053efdc9435524bead1a9a /meta/recipes-extended/stat
parent23f1dddbf9cf783d90040b67978d1291b16a13de (diff)
downloadopenembedded-core-2abc776393f8b5574dd9cf614ff1ae4b460e4d8c.tar.gz
stat: use update-alt for stat
Three different recipes provide the stat program, busybox, coreutils and stat. Ensure that they are installed to the same place and use update-alternative with the correct priorities to have the correct binary installed. [YOCTO #6415] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/stat')
-rw-r--r--meta/recipes-extended/stat/stat_3.3.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta/recipes-extended/stat/stat_3.3.bb b/meta/recipes-extended/stat/stat_3.3.bb
index c9edb1de5b..6754fb8cbd 100644
--- a/meta/recipes-extended/stat/stat_3.3.bb
+++ b/meta/recipes-extended/stat/stat_3.3.bb
@@ -12,10 +12,17 @@ SRC_URI[md5sum] = "37e247e8e400ad9205f1b0500b728fd3"
SRC_URI[sha256sum] = "7071f0384a423a938dd542c1f08547a02824f6359acd3ef3f944b2c4c2d1ee09"
do_install() {
- install -d ${D}${bindir} ${D}${mandir}/man1
- install -m 755 stat ${D}${bindir}
+ install -d ${D}${base_bindir} ${D}${mandir}/man1
+ install -m 755 stat ${D}${base_bindir}/stat.stat
install -m 644 stat.1 ${D}${mandir}/man1
}
+inherit update-alternatives
+
+ALTERNATIVE_${PN} = "stat"
+ALTERNATIVE_PRIORITY[stat] = "200"
+ALTERNATIVE_LINK_NAME[stat] = "${base_bindir}/stat"
+ALTERNATIVE_TARGET[stat] = "${base_bindir}/stat.stat"
+
BBCLASSEXTEND = "native"