aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2011-03-16 14:41:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-16 13:39:42 +0000
commit71782f844552636bb0158e7a2271e849259a48c0 (patch)
tree592e6a01bb907dab391c31a5936709b595156e4b /meta/recipes-extended/slang
parent361f7536e75893c51cdcb2c6449e300ee2bbd53a (diff)
downloadopenembedded-core-71782f844552636bb0158e7a2271e849259a48c0.tar.gz
slang: export INST_LIB_DIR to fix compile problems
Export "INST_LIB_DIR" in do_install to slang/slsh to fix cross compile warnings Fixes [YOCTO #812] Add necessary files to run slsh. Signed-off-by: Kang Kai <kai.kang@windriver.com>
Diffstat (limited to 'meta/recipes-extended/slang')
-rw-r--r--meta/recipes-extended/slang/slang_2.2.2.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-extended/slang/slang_2.2.2.bb b/meta/recipes-extended/slang/slang_2.2.2.bb
index 7fe76af4cc..f77a946c6e 100644
--- a/meta/recipes-extended/slang/slang_2.2.2.bb
+++ b/meta/recipes-extended/slang/slang_2.2.2.bb
@@ -10,7 +10,7 @@ to recode S-Lang procedures in C if you need to."
SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "pcre"
-PR = "r0"
+PR = "r1"
LICENSE = "GPL Artistic"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
@@ -23,3 +23,9 @@ inherit autotools
SRC_URI[md5sum] = "974437602a781cfe92ab61433dd16d03"
SRC_URI[sha256sum] = "cfaf8551fa3855f9b0043309bb553ef6d457f931b404df5a6ba6a5a69371fc42"
+
+do_install() {
+ oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib'
+}
+
+FILES_${PN} += "${datadir}/slsh/"