aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang/slang_2.2.4.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2012-12-20 11:50:38 +0100
committerSaul Wold <sgw@linux.intel.com>2012-12-25 14:00:19 -0800
commit807aa2079c5884b6bd1afb705c31090c87d14dc5 (patch)
treef65aea685996acc543163d2121c90bea82dbe1e0 /meta/recipes-extended/slang/slang_2.2.4.bb
parentbbd55cc34ca893c7202634fe138cedb2f380be56 (diff)
downloadopenembedded-core-807aa2079c5884b6bd1afb705c31090c87d14dc5.tar.gz
slang: added gnu-configize for AArch64 support
Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/slang/slang_2.2.4.bb')
-rw-r--r--meta/recipes-extended/slang/slang_2.2.4.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-extended/slang/slang_2.2.4.bb b/meta/recipes-extended/slang/slang_2.2.4.bb
index 60aac666c7..b70e663139 100644
--- a/meta/recipes-extended/slang/slang_2.2.4.bb
+++ b/meta/recipes-extended/slang/slang_2.2.4.bb
@@ -29,6 +29,14 @@ SRC_URI[sha256sum] = "9a8257a9a2a55099af858b13338dc8f3a06dd2069f46f0df2c9c3bb84a
EXTRA_OECONF += " --without-z --without-png --without-onig --x-includes=${STAGING_DIR_HOST}/usr/include/X11 --x-libraries=${STAGING_DIR_HOST}/usr/lib"
+do_configure_prepend() {
+ # slang keeps configure.ac and rest of autoconf files in autoconf/ directory
+ # we have to go there to be able to run gnu-configize cause it expects configure.{in,ac}
+ # to be present. Resulting files land in autoconf/autoconf/ so we need to move them.
+ cd ${S}/autoconf && gnu-configize --force && mv autoconf/config.* .
+ cd ${B}
+}
+
do_install() {
oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib'
}