aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang/slang_2.2.4.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-04-15 15:16:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-18 05:47:56 +0100
commit2f5ab5632e9c7be5fef5fcb57c52dbec7d0880f9 (patch)
tree2bb3aec8371956e0fd3a361804d0aae692edfdbb /meta/recipes-extended/slang/slang_2.2.4.bb
parentcb181eb4dc2c20a70153f9d69d732978566ba4f7 (diff)
downloadopenembedded-core-2f5ab5632e9c7be5fef5fcb57c52dbec7d0880f9.tar.gz
slang: Update to 2.2.4
- Removed fix-uclibc.patch as it's no longer required by the upstream - Removed requirment for png as we only need limited support for slang - fix license - disable Parallel Make Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/slang/slang_2.2.4.bb')
-rw-r--r--meta/recipes-extended/slang/slang_2.2.4.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-extended/slang/slang_2.2.4.bb b/meta/recipes-extended/slang/slang_2.2.4.bb
new file mode 100644
index 0000000000..2b000a4088
--- /dev/null
+++ b/meta/recipes-extended/slang/slang_2.2.4.bb
@@ -0,0 +1,34 @@
+SUMMARY = "The shared library for the S-Lang extension language"
+
+DESCRIPTION = "S-Lang is an interpreted language and a programming library. The \
+S-Lang language was designed so that it can be easily embedded into \
+a program to provide the program with a powerful extension language. \
+The S-Lang library, provided in this package, provides the S-Lang \
+extension language. S-Lang's syntax resembles C, which makes it easy \
+to recode S-Lang procedures in C if you need to."
+
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "pcre"
+PR = "r5"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
+
+
+SRC_URI = "ftp://space.mit.edu/pub/davis/slang/v2.2/slang-${PV}.tar.bz2 \
+ "
+
+inherit autotools
+
+SRC_URI[md5sum] = "7fcfd447e378f07dd0c0bae671fe6487"
+SRC_URI[sha256sum] = "9a8257a9a2a55099af858b13338dc8f3a06dd2069f46f0df2c9c3bb84a01d5db"
+
+EXTRA_OECONF += " --without-png"
+do_install() {
+ oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib'
+}
+
+FILES_${PN} += "${datadir}/slsh/"
+
+PARALLEL_MAKE = ""