aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/shadow
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-08-30 16:05:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-31 19:58:23 +0100
commit48ec20d1331eb665d9fc1a06bdb1ea79e4513159 (patch)
tree8f6b4d5e76a02056615dbc909b0923a3524f6f46 /meta/recipes-extended/shadow
parent48dcb8fc7b669b27160dde33079f40551853702b (diff)
downloadopenembedded-core-48ec20d1331eb665d9fc1a06bdb1ea79e4513159.tar.gz
shadow: Fix rpm failed dependencies when install
There are some links become invalid after rename, so that failed dependencies detected when install rpm package. This commit update links to resolve it. [YOCTO #1158] got fixed. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/shadow')
-rw-r--r--meta/recipes-extended/shadow/shadow_4.1.4.3.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-extended/shadow/shadow_4.1.4.3.bb b/meta/recipes-extended/shadow/shadow_4.1.4.3.bb
index 728b8e5b20..5bc4a6183e 100644
--- a/meta/recipes-extended/shadow/shadow_4.1.4.3.bb
+++ b/meta/recipes-extended/shadow/shadow_4.1.4.3.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=08c553a87d4e51bbed50b20e0adcaede \
DEPENDS = "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_PLUGINS}', '', d)}"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://pkg-shadow.alioth.debian.org/releases/${BPN}-${PV}.tar.bz2 \
file://login_defs_pam.sed \
@@ -97,6 +97,11 @@ do_install_append() {
mv ${D}${sbindir}/vipw ${D}${base_sbindir}/vipw.${PN}
mv ${D}${bindir}/login ${D}${base_bindir}/login.${PN}
+ # Handle link properly after rename, otherwise missing files would
+ # lead rpm failed dependencies.
+ ln -sf vipw.${PN} ${D}${base_sbindir}/vigr.${PN}
+ ln -sf newgrp.${PN} ${D}${bindir}/sg
+
# Ensure we add a suitable securetty file to the package that has
# most common embedded TTYs defined.
if [ ! -z "${SERIAL_CONSOLE}" ]; then