aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sed
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-05-22 12:38:19 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-30 10:43:42 +0100
commitcd059cb57efa2aad332ef2fc7f1f411afce82b73 (patch)
tree2e93b5e8ad11824b03517c4e7ee5d96738c3452b /meta/recipes-extended/sed
parent87d43530b434e5be139b845d6b96bbf2d885867d (diff)
downloadopenembedded-core-cd059cb57efa2aad332ef2fc7f1f411afce82b73.tar.gz
sed: use BPN for alternatives
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-extended/sed')
-rw-r--r--meta/recipes-extended/sed/sed_4.1.2.bb4
-rw-r--r--meta/recipes-extended/sed/sed_4.2.1.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-extended/sed/sed_4.1.2.bb b/meta/recipes-extended/sed/sed_4.1.2.bb
index 8baa180f72..ca22736b7f 100644
--- a/meta/recipes-extended/sed/sed_4.1.2.bb
+++ b/meta/recipes-extended/sed/sed_4.1.2.bb
@@ -17,12 +17,12 @@ inherit autotools update-alternatives gettext
do_install () {
autotools_do_install
install -d ${D}${base_bindir}
- mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${PN}
+ mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${BPN}
rmdir ${D}${bindir}/
}
ALTERNATIVE_NAME = "sed"
-ALTERNATIVE_PATH = "sed.${PN}"
+ALTERNATIVE_PATH = "sed.${BPN}"
ALTERNATIVE_LINK = "${base_bindir}/sed"
ALTERNATIVE_PRIORITY = "100"
diff --git a/meta/recipes-extended/sed/sed_4.2.1.bb b/meta/recipes-extended/sed/sed_4.2.1.bb
index 0fceecd6be..b39eca0bc0 100644
--- a/meta/recipes-extended/sed/sed_4.2.1.bb
+++ b/meta/recipes-extended/sed/sed_4.2.1.bb
@@ -18,12 +18,12 @@ EXTRA_OECONF = "--disable-acl"
do_install () {
autotools_do_install
install -d ${D}${base_bindir}
- mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${PN}
+ mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${BPN}
rmdir ${D}${bindir}/
}
ALTERNATIVE_NAME = "sed"
-ALTERNATIVE_PATH = "sed.${PN}"
+ALTERNATIVE_PATH = "sed.${BPN}"
ALTERNATIVE_LINK = "${base_bindir}/sed"
ALTERNATIVE_PRIORITY = "100"