aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sed
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-07-26 17:34:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-15 14:18:42 +0100
commitc42bff2e0718c40d87b91672bec76c63e4c91c0a (patch)
tree16aa033f88fb249214a02383077f10197ecdddfe /meta/recipes-extended/sed
parent00d0d074a452bb5dc54ad12f44e444a742380860 (diff)
downloadopenembedded-core-c42bff2e0718c40d87b91672bec76c63e4c91c0a.tar.gz
sed: cleanup update-alternatives deprecated code
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/sed')
-rw-r--r--meta/recipes-extended/sed/sed_4.1.2.bb9
-rw-r--r--meta/recipes-extended/sed/sed_4.2.1.bb9
2 files changed, 8 insertions, 10 deletions
diff --git a/meta/recipes-extended/sed/sed_4.1.2.bb b/meta/recipes-extended/sed/sed_4.1.2.bb
index 3455c20703..821ff65fe5 100644
--- a/meta/recipes-extended/sed/sed_4.1.2.bb
+++ b/meta/recipes-extended/sed/sed_4.1.2.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://sed/sed.h;beginline=1;endline=17;md5=e00ffd1837f298439a214fd197f6a407"
SECTION = "console/utils"
-PR = "r6"
+PR = "r7"
SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz \
file://fix_return_type.patch \
@@ -18,13 +18,12 @@ inherit autotools update-alternatives gettext
do_install () {
autotools_do_install
install -d ${D}${base_bindir}
- mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${BPN}
+ mv ${D}${bindir}/sed ${D}${base_bindir}/sed
rmdir ${D}${bindir}/
}
-ALTERNATIVE_NAME = "sed"
-ALTERNATIVE_PATH = "sed.${BPN}"
-ALTERNATIVE_LINK = "${base_bindir}/sed"
+ALTERNATIVE_${PN} = "sed"
+ALTERNATIVE_LINK_NAME[sed] = "${base_bindir}/sed"
ALTERNATIVE_PRIORITY = "100"
BBCLASSEXTEND = "native"
diff --git a/meta/recipes-extended/sed/sed_4.2.1.bb b/meta/recipes-extended/sed/sed_4.2.1.bb
index b39eca0bc0..96c509a170 100644
--- a/meta/recipes-extended/sed/sed_4.2.1.bb
+++ b/meta/recipes-extended/sed/sed_4.2.1.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
file://sed/sed.h;beginline=1;endline=17;md5=767ab3a06d7584f6fd0469abaec4412f"
SECTION = "console/utils"
-PR = "r3"
+PR = "r5"
SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz"
@@ -18,13 +18,12 @@ EXTRA_OECONF = "--disable-acl"
do_install () {
autotools_do_install
install -d ${D}${base_bindir}
- mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${BPN}
+ mv ${D}${bindir}/sed ${D}${base_bindir}/sed
rmdir ${D}${bindir}/
}
-ALTERNATIVE_NAME = "sed"
-ALTERNATIVE_PATH = "sed.${BPN}"
-ALTERNATIVE_LINK = "${base_bindir}/sed"
+ALTERNATIVE_${PN} = "sed"
+ALTERNATIVE_LINK_NAME[sed] = "${base_bindir}/sed"
ALTERNATIVE_PRIORITY = "100"
BBCLASSEXTEND = "native"