aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sed
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-09-01 11:16:05 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 09:50:50 +0100
commit8232e014379dcb51938b5328c30630997da05f38 (patch)
tree3c0e7c4abb6d1d049bb8f479a1edd40dfdfd37bf /meta/recipes-extended/sed
parentc56bab6b25350df34b3dd9b191d368c05ac7f96e (diff)
downloadopenembedded-core-8232e014379dcb51938b5328c30630997da05f38.tar.gz
sed: Inherit update-altenatives to handle the install priority
This method is simple and preferred by poky Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/recipes-extended/sed')
-rw-r--r--meta/recipes-extended/sed/sed_4.1.2.bb16
1 files changed, 5 insertions, 11 deletions
diff --git a/meta/recipes-extended/sed/sed_4.1.2.bb b/meta/recipes-extended/sed/sed_4.1.2.bb
index 09bd3e18cc..e243f3e25f 100644
--- a/meta/recipes-extended/sed/sed_4.1.2.bb
+++ b/meta/recipes-extended/sed/sed_4.1.2.bb
@@ -4,14 +4,14 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://sed/sed.h;beginline=1;endline=17;md5=e00ffd1837f298439a214fd197f6a407"
SECTION = "console/utils"
-PR = "r3"
+PR = "r4"
DEPENDS = "gettext"
SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz \
file://fix_return_type.patch"
-inherit autotools
+inherit autotools update-alternatives
do_install () {
autotools_do_install
@@ -19,14 +19,8 @@ do_install () {
mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${PN}
}
-
-pkg_postinst_${PN} () {
- update-alternatives --install ${base_bindir}/sed sed sed.${PN} 100
-}
-
-
-pkg_prerm_${PN} () {
- update-alternatives --remove sed sed.${PN}
-}
+ALTERNATIVE_NAME = "sed"
+ALTERNATIVE_PATH = "sed.${PN}"
+ALTERNATIVE_PRIORITY = "100"
BBCLASSEXTEND = "native"