aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sed
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-19 13:02:58 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-19 14:05:42 +0100
commit3c32d9c53f1789bdb072a5957ddd83e5c4e16914 (patch)
tree01a6606cc13d0e05641b5cd102f39a87b7d65f97 /meta/recipes-extended/sed
parent2433846255767d5a22fb2c7b2b723f290ac12fbf (diff)
downloadopenembedded-core-3c32d9c53f1789bdb072a5957ddd83e5c4e16914.tar.gz
sed: Fix gplv2 version to work with recent gettext
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/sed')
-rw-r--r--meta/recipes-extended/sed/sed-4.1.2/Makevars25
-rw-r--r--meta/recipes-extended/sed/sed_4.1.2.bb7
2 files changed, 31 insertions, 1 deletions
diff --git a/meta/recipes-extended/sed/sed-4.1.2/Makevars b/meta/recipes-extended/sed/sed-4.1.2/Makevars
new file mode 100644
index 0000000000..8b09f53b0f
--- /dev/null
+++ b/meta/recipes-extended/sed/sed-4.1.2/Makevars
@@ -0,0 +1,25 @@
+# Makefile variables for PO directory in any package using GNU gettext.
+
+# Usually the message domain is the same as the package name.
+DOMAIN = $(PACKAGE)
+
+# These two variables depend on the location of this directory.
+subdir = po
+top_builddir = ..
+
+# These options get passed to xgettext.
+XGETTEXT_OPTIONS = --keyword=_ --keyword=N_
+
+# This is the copyright holder that gets inserted into the header of the
+# $(DOMAIN).pot file. Set this to the copyright holder of the surrounding
+# package. (Note that the msgstr strings, extracted from the package's
+# sources, belong to the copyright holder of the package.) Translators are
+# expected to transfer the copyright for their translations to this person
+# or entity, or to disclaim their copyright. The empty string stands for
+# the public domain; in this case the translators are expected to disclaim
+# their copyright.
+COPYRIGHT_HOLDER = Free Software Foundation, Inc.
+
+# This is the list of locale categories, beyond LC_MESSAGES, for which the
+# message catalogs shall be used. It is usually empty.
+EXTRA_LOCALE_CATEGORIES =
diff --git a/meta/recipes-extended/sed/sed_4.1.2.bb b/meta/recipes-extended/sed/sed_4.1.2.bb
index 821ff65fe5..5fa4e87521 100644
--- a/meta/recipes-extended/sed/sed_4.1.2.bb
+++ b/meta/recipes-extended/sed/sed_4.1.2.bb
@@ -8,13 +8,18 @@ PR = "r7"
SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz \
file://fix_return_type.patch \
- file://sed-4.1.2_fix_for_automake-1.12.patch "
+ file://sed-4.1.2_fix_for_automake-1.12.patch \
+ file://Makevars"
SRC_URI[md5sum] = "928f0e06422f414091917401f1a834d0"
SRC_URI[sha256sum] = "638e837ba765d5da0a30c98b57c2953cecea96827882f594612acace93ceeeab"
inherit autotools update-alternatives gettext
+do_configure_prepend () {
+ cp ${WORKDIR}/Makevars ${S}/po/
+}
+
do_install () {
autotools_do_install
install -d ${D}${base_bindir}