aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/procps
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-07-26 17:24:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-15 14:18:41 +0100
commit04c412803b7faf7ac87621be2c03b1f17a1f6c8c (patch)
treeb0298a6a2b5a9136a3110d22c7f7704ab60479f5 /meta/recipes-extended/procps
parentb69a6cea664e51b1a127767ecaea94b90b548d75 (diff)
downloadopenembedded-core-04c412803b7faf7ac87621be2c03b1f17a1f6c8c.tar.gz
procps: cleanup update-alternatives deprecated code
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/procps')
-rw-r--r--meta/recipes-extended/procps/procps.inc9
-rw-r--r--meta/recipes-extended/procps/procps_3.2.8.bb9
2 files changed, 8 insertions, 10 deletions
diff --git a/meta/recipes-extended/procps/procps.inc b/meta/recipes-extended/procps/procps.inc
index 80080fc488..6ee4a04f81 100644
--- a/meta/recipes-extended/procps/procps.inc
+++ b/meta/recipes-extended/procps/procps.inc
@@ -13,8 +13,13 @@ DEPENDS = "ncurses"
SRC_URI = "http://procps.sourceforge.net/procps-${PV}.tar.gz \
file://install.patch"
-inherit autotools
+inherit autotools update-alternatives
FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
FILES_SOLIBSDEV = ""
-FILES_${PN} += ""
+
+ALTERNATIVE_${PN} = "top uptime free pkill pmap kill sysctl ps pgrep pwdx watch"
+ALTERNATIVE_LINK_NAME[kill] = "${base_bindir}/kill"
+ALTERNATIVE_LINK_NAME[sysctl] = "${base_sbindir}/sysctl"
+ALTERNATIVE_LINK_NAME[ps] = "${base_bindir}/ps"
+ALTERNATIVE_PRIORITY = "110"
diff --git a/meta/recipes-extended/procps/procps_3.2.8.bb b/meta/recipes-extended/procps/procps_3.2.8.bb
index 5508eb05b3..7b011a0147 100644
--- a/meta/recipes-extended/procps/procps_3.2.8.bb
+++ b/meta/recipes-extended/procps/procps_3.2.8.bb
@@ -1,13 +1,6 @@
require procps.inc
-PR = "r8"
-
-inherit update-alternatives
-
-ALTERNATIVE_LINKS = "${bindir}/top ${bindir}/uptime ${bindir}/free ${bindir}/pkill ${bindir}/pmap \
- ${base_bindir}/kill ${base_sbindir}/sysctl ${base_bindir}/ps \
- ${bindir}/pgrep ${bindir}/pwdx ${bindir}/watch"
-ALTERNATIVE_PRIORITY = "110"
+PR = "r9"
SRC_URI += "file://procmodule.patch \
file://psmodule.patch \