aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/perl
diff options
context:
space:
mode:
authorXin Ouyang <Xin.Ouyang@windriver.com>2012-11-30 18:29:59 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-03 15:22:34 +0000
commit3230d943699c77f3fe9ce9d9949eae21d825186d (patch)
tree7ddb287f682ab3c0ad27bd4829a47c2745e33e9e /meta/recipes-extended/perl
parent821401df8cd79e4878ad87f918b1ce8d0da141ec (diff)
downloadopenembedded-core-3230d943699c77f3fe9ce9d9949eae21d825186d.tar.gz
libxml-sax-base-perl: add recipe for libxml-sax-perl
If libxml-sax-base-perl is not installed on the target, libxml-sax-perl would be fail to use. So add the recipe. # cat > test.pl <<-EOF #!/usr/bin/perl use XML::SAX; EOF # perl ./test.pl Can't locate XML/SAX/Exception.pm in @INC ... Also inherit allarch for three perl modules. Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/perl')
-rw-r--r--meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb4
-rw-r--r--meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb24
-rw-r--r--meta/recipes-extended/perl/libxml-sax-perl_0.99.bb6
3 files changed, 29 insertions, 5 deletions
diff --git a/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb b/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb
index cf89cb6952..928440377c 100644
--- a/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb
+++ b/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "XML::NamespaceSupport offers a simple way to process namespace-ba
SECTION = "libs"
LICENSE = "Artistic-1.0 | GPL-1.0+"
-PR = "r2"
+PR = "r3"
LIC_FILES_CHKSUM = "file://META.yml;beginline=22;endline=22;md5=3b2b564dae8b9af9e8896e85c07dcbe5"
@@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "6d8151f0a3f102313d76b64bfd1c2d9ed46bfe63a16f038e7d860fda28
S = "${WORKDIR}/XML-NamespaceSupport-${PV}"
-inherit cpan
+inherit cpan allarch
BBCLASSEXTEND="native"
diff --git a/meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb b/meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb
new file mode 100644
index 0000000000..d87c044119
--- /dev/null
+++ b/meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Base class SAX Drivers and Filters"
+DESCRIPTION = "This module has a very simple task - to be a base class for \
+PerlSAX drivers and filters. It's default behaviour is to pass \
+the input directly to the output unchanged. It can be useful to \
+use this module as a base class so you don't have to, for example, \
+implement the characters() callback."
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+RDEPENDS += "perl-module-extutils-makemaker"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://dist.ini;endline=5;md5=8f9c9a55340aefaee6e9704c88466446"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-Base-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "38c8c3247dfd080712596118d70dbe32"
+SRC_URI[sha256sum] = "666270318b15f88b8427e585198abbc19bc2e6ccb36dc4c0a4f2d9807330219e"
+
+S = "${WORKDIR}/XML-SAX-Base-${PV}"
+
+inherit cpan allarch
+
+BBCLASSEXTEND = "native"
diff --git a/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb b/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
index 3a0873fe41..647cb77fa8 100644
--- a/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
+++ b/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
@@ -10,8 +10,8 @@ javaness."
SECTION = "libs"
LICENSE = "Artistic-1.0 | GPL-1.0+"
DEPENDS += "libxml-namespacesupport-perl-native"
-RDEPENDS_${PN} += "libxml-namespacesupport-perl perl-module-file-temp"
-PR = "r1"
+RDEPENDS_${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp"
+PR = "r2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"
@@ -22,6 +22,6 @@ SRC_URI[sha256sum] = "32b04b8e36b6cc4cfc486de2d859d87af5386dd930f2383c49347050d6
S = "${WORKDIR}/XML-SAX-${PV}"
-inherit cpan
+inherit cpan allarch
BBCLASSEXTEND = "native"