summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2019-03-06 09:36:12 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-06 23:12:06 +0000
commitc4df63dc705c3d8594517af2c2d5eddb36c176f7 (patch)
treea5abf77e29a6192a9da8d260284ef722b2bde77b /meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
parentace6911e663709f07ca73aa72f6bb4f4111b2749 (diff)
downloadopenembedded-core-c4df63dc705c3d8594517af2c2d5eddb36c176f7.tar.gz
packagegroup-core-base-utils: Introduce new base-utils packagegroup
This packagegroup is intended to provide all of the functionality found in other VIRTUAL-RUNTIME_base-utils providers through full packages rather than an all-on-one package. Document how to make use of this in local.conf.sample.extended. Introduce VIRTUAL-RUNTIME-vim and default this to vim-tiny to allow for a differently features vim to be used instead. Signed-off-by: Tom Rini <trini@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb')
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb b/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
new file mode 100644
index 0000000000..431dbb0926
--- /dev/null
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-base-utils.bb
@@ -0,0 +1,58 @@
+#
+# Copyright (C) 2019 Konsulko Group
+#
+
+SUMMARY = "Full-featured set of base utils"
+DESCRIPTION = "Package group bringing in packages needed to provide much of the base utils type functionality found in busybox"
+
+inherit packagegroup
+
+VIRTUAL-RUNTIME_vim ?= "vim-tiny"
+
+RDEPENDS_${PN} = "\
+ base-passwd \
+ bash \
+ bind-utils \
+ bzip2 \
+ coreutils \
+ cpio \
+ ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "debianutils-run-parts", d)} \
+ dhcp-client \
+ ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "dhcp-server", d)} \
+ diffutils \
+ ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "dpkg-start-stop", d)} \
+ e2fsprogs \
+ ed \
+ file \
+ findutils \
+ gawk \
+ grep \
+ gzip \
+ ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "ifupdown", d)} \
+ inetutils \
+ inetutils-ping \
+ inetutils-telnet \
+ inetutils-tftp \
+ inetutils-traceroute \
+ iproute2 \
+ ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "kbd", "", d)} \
+ kmod \
+ less \
+ lzip \
+ ncurses-tools \
+ net-tools \
+ parted \
+ patch \
+ procps \
+ psmisc \
+ sed \
+ shadow-base \
+ tar \
+ time \
+ unzip \
+ util-linux \
+ ${VIRTUAL-RUNTIME_vim} \
+ wget \
+ which \
+ xz \
+ "