aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-08-06 20:05:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-11 10:46:58 +0100
commitbf2f8abff4eb55cd960065eaba032c96068acf08 (patch)
tree4b84eca34579ba659b14ac2d2991017fd37da6ca /meta/recipes-extended/newt
parenta81d4fd4ac3b2cfb144650a9bdde918d9f7d73a2 (diff)
downloadopenembedded-core-bf2f8abff4eb55cd960065eaba032c96068acf08.tar.gz
libnewt: fix recompile error
Fixed: NOTE: make -j 32 make: *** No rule to make target `/path/to/sysroot/4.9.0/include/stddef.h', needed by `test.o'. Stop. This happens when upgrade gcc from 4.9.0 to 4.9.1, and the .depend isn't regenerated when recompile, the content of the .depend are: [snip] test.o: /path/to/sysroot/4.9.0/include/stddef.h [snip] And Makefile includes the .depend file if it exists, so there would be errors when /path/to/sysroot/4.9.0/include/stddef.h doesn't exist. Remove .depend will fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/newt')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.17.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.17.bb b/meta/recipes-extended/newt/libnewt_0.52.17.bb
index 09b017e24e..28d5cf1a34 100644
--- a/meta/recipes-extended/newt/libnewt_0.52.17.bb
+++ b/meta/recipes-extended/newt/libnewt_0.52.17.bb
@@ -46,4 +46,9 @@ do_configure_prepend() {
sh autogen.sh
}
+do_compile_prepend() {
+ # Make sure the recompile is OK
+ rm -f ${B}/.depend
+}
+
FILES_whiptail = "${bindir}/whiptail"