aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-12-12 18:48:07 +0800
committerSaul Wold <sgw@linux.intel.com>2012-12-14 15:17:19 -0800
commitaa591ecb1aac1c0308c05dbac81bc056869a2c3e (patch)
tree3367aed94d63918a1c525bdd5f2c6e8db50b9d28 /meta/recipes-extended/newt
parent77092eeaadfd89375a6aea6d170664f4d3e6f6dd (diff)
downloadopenembedded-core-aa591ecb1aac1c0308c05dbac81bc056869a2c3e.tar.gz
newt: enable python support
Compile newt with python support. There may be packages that need newt's python extension. Add python to DEPENDS. And add patch fix_python_fpic.patch to compile python .so module with flag -fPIC. Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/newt')
-rw-r--r--meta/recipes-extended/newt/files/fix_python_fpic.patch24
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.14.bb24
2 files changed, 42 insertions, 6 deletions
diff --git a/meta/recipes-extended/newt/files/fix_python_fpic.patch b/meta/recipes-extended/newt/files/fix_python_fpic.patch
new file mode 100644
index 0000000000..3ef94e0c56
--- /dev/null
+++ b/meta/recipes-extended/newt/files/fix_python_fpic.patch
@@ -0,0 +1,24 @@
+Fix relocations warning when compile python module
+
+After enable python support in newt, bitbake complains warning:
+
+WARNING: QA Issue: ELF binary '/mnt/sda10/poky-all-platform/build/tmp/work/i586-poky-linux/libnewt/0.52.14-r2/packages-split/libnewt-python/usr/lib/python2.7/site-packages/_snackmodule.so' has relocations in .text
+
+Add flag -fPIC to compile _snackmodule.so to fix the warning.
+
+Signed-off-by: Kang Kai <kai.kang@windriver.com>
+
+Upstream-Status: Pending
+
+---
+--- newt-0.52.14/Makefile.in 2012-12-04 17:27:27.578915801 +0800
++++ newt-0.52.14/Makefile.in.new 2012-12-04 17:28:43.274918472 +0800
+@@ -84,7 +84,7 @@
+ PIFLAGS=`$$ver-config --includes`; \
+ PLDFLAGS=`$$ver-config --ldflags`; \
+ PLFLAGS=`$$ver-config --libs`; \
+- $(CC) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c ;\
++ $(CC) $(SHCFLAGS) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c ;\
+ $(CC) --shared $$PLDFLAGS $$PLFLAGS $(LDFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L. -lnewt $(LIBS);\
+ done || :
+ touch $@
diff --git a/meta/recipes-extended/newt/libnewt_0.52.14.bb b/meta/recipes-extended/newt/libnewt_0.52.14.bb
index 0208695699..c1ec029c56 100644
--- a/meta/recipes-extended/newt/libnewt_0.52.14.bb
+++ b/meta/recipes-extended/newt/libnewt_0.52.14.bb
@@ -15,28 +15,40 @@ LICENSE = "LGPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
# slang needs to be >= 2.2
-DEPENDS = "slang popt"
+DEPENDS = "slang popt python"
-PR = "r1"
+PR = "r2"
SRC_URI = "https://fedorahosted.org/releases/n/e/newt/newt-${PV}.tar.gz \
file://remove_slang_include.patch \
file://fix_SHAREDDIR.patch \
- file://cross_ar.patch"
+ file://cross_ar.patch \
+ file://fix_python_fpic.patch"
SRC_URI[md5sum] = "eb78c6bb658b92ec7198908b5b8d0e37"
SRC_URI[sha256sum] = "f70f4f58baa60388ddf2e39249ffb00898fb40f2b2767e42e2ab51fe4b40978e"
S = "${WORKDIR}/newt-${PV}"
-EXTRA_OECONF = "--without-python --without-tcl"
+EXTRA_OECONF = "--without-tcl"
-inherit autotools
+inherit autotools pythonnative python-dir
-PACKAGES_prepend = "whiptail "
+EXTRA_OEMAKE = "PYTHONVERS=${PYTHON_DIR}"
+
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+export BUILD_SYS
+export HOST_SYS
+
+PACKAGES_prepend = "whiptail ${PN}-python "
do_configure_prepend() {
sh autogen.sh
}
FILES_whiptail = "${bindir}/whiptail"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug/"
+FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
+FILES_${PN}-staticdev = "${libdir}/*.a"